summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-07-30 13:32:31 +0200
committerMartin Väth <martin@mvath.de>2018-07-30 13:32:31 +0200
commit8a6e44ee1b1af5a0aef207b7d9d8e3a2e373e870 (patch)
tree56d486e22f04967d4bad2bcd47394a6720680702
parentapp-portage/eix: Alpha version bump (diff)
downloadmv-8a6e44ee1b1af5a0aef207b7d9d8e3a2e373e870.tar.gz
mv-8a6e44ee1b1af5a0aef207b7d9d8e3a2e373e870.tar.bz2
mv-8a6e44ee1b1af5a0aef207b7d9d8e3a2e373e870.zip
app-text/podofo: Version bump. sys-block/zram-init: Add arches
-rw-r--r--app-text/podofo/Manifest2
-rw-r--r--app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch26
-rw-r--r--app-text/podofo/podofo-0.9.6_p20180715.ebuild (renamed from app-text/podofo/podofo-0.9.6_pre20171027.ebuild)12
-rw-r--r--metadata/pkg_desc_index4
-rw-r--r--sys-block/zram-init/zram-init-7.1-r1.ebuild (renamed from sys-block/zram-init/zram-init-7.1.ebuild)3
5 files changed, 7 insertions, 40 deletions
diff --git a/app-text/podofo/Manifest b/app-text/podofo/Manifest
index 5efd9abd..ef945566 100644
--- a/app-text/podofo/Manifest
+++ b/app-text/podofo/Manifest
@@ -1 +1 @@
-DIST podofo-0.9.6_pre20171027.tar.xz 919504 SHA512 db1ac836abd7be0d2cc3c27114c7134de9de8ba931a6a8265514fedefe3c6f06a24371f7a5425c8b7251fe7166bc27f07733cba878ad24c12651c8c051cac8be
+DIST podofo-0.9.6_p20180715.tar.xz 747444 SHA512 4c9b09c716128110b47d6a02f118eb80b6009e9e79dbc83ff804a57f0abc011b789de9287b68a6c1d6704ef386f8062a3a495408af8a832782f0bf0128190a1f
diff --git a/app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch b/app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch
deleted file mode 100644
index 2b25dc7b..00000000
--- a/app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 85e66b066de98f38e0430428906d5cf5396876a0 Mon Sep 17 00:00:00 2001
-From: Michelangelo Scopelliti <kernelpanic@gmx.it>
-Date: Thu, 23 Nov 2017 12:29:36 +0000
-Subject: [PATCH] Fix to compile with libressl (does not have OPENSSL_init_ssl)
-
-Bug: https://bugs.gentoo.org/635890
----
- tools/podofosign/podofosign.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/podofosign/podofosign.cpp b/tools/podofosign/podofosign.cpp
-index a7be1e5..5c9d146 100644
---- a/tools/podofosign/podofosign.cpp
-+++ b/tools/podofosign/podofosign.cpp
-@@ -875,7 +875,7 @@ int main( int argc, char* argv[] )
- outputfile = NULL;
- }
-
--#ifdef PODOFO_HAVE_OPENSSL_1_1
-+#if defined (PODOFO_HAVE_OPENSSL_1_1) && !defined (LIBRESSL_VERSION_NUMBER)
- OPENSSL_init_ssl(0, NULL);
- #else
- OpenSSL_add_all_algorithms();
---
-2.13.6
-
diff --git a/app-text/podofo/podofo-0.9.6_pre20171027.ebuild b/app-text/podofo/podofo-0.9.6_p20180715.ebuild
index f4a82fcb..6c94e0cc 100644
--- a/app-text/podofo/podofo-0.9.6_pre20171027.ebuild
+++ b/app-text/podofo/podofo-0.9.6_p20180715.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="https://sourceforge.net/projects/podofo/"
SRC_URI="mirror://gentoo/${P}.tar.xz"
LICENSE="GPL-2 LGPL-2.1"
-SLOT="0/${PV}"
+SLOT="0/${PV%_*}"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="+boost idn libressl lua-slotted lua51 lua52 debug test +tools"
REQUIRED_USE="test? ( tools ) lua52? ( lua51 )"
@@ -36,20 +36,12 @@ DEPEND="${RDEPEND}
boost? ( dev-util/boost-build )
test? ( dev-util/cppunit )"
-PATCHES=(
- "${FILESDIR}/${P}-libressl-bug-635890.patch"
-)
-
DOCS="AUTHORS ChangeLog TODO"
src_prepare() {
cmake-utils_src_prepare
local x sed_args
- # The 0.9.6 ABI is not necessarily stable, so make PODOFO_SOVERSION
- # equal to ${PV}.
- sed -e 's|${PODOFO_VERSION_PATCH}|\0_'${PV##*_}'|' -i CMakeLists.txt || die
-
# bug 620934 - Disable linking with cppunit when possible, since it
# triggers errors with some older compilers.
use test || sed -e 's:^FIND_PACKAGE(CppUnit):#\0:' -i CMakeLists.txt || die
@@ -128,6 +120,7 @@ src_prepare() {
}
src_configure() {
+
# Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
filter-flags -fvisibility-inlines-hidden
@@ -155,6 +148,7 @@ src_configure() {
fi
cmake-utils_src_configure
+ mkdir -p "${S}/test/TokenizerTest/objects" || die
}
src_test() {
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index b5b288f0..64c1cc51 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -49,7 +49,7 @@ app-shells/zshrc-mv 4.8: A zshrc file initializing zsh specific interactive feat
app-text/ispell 3.3.02-r1 3.4.00: fast screen-oriented spelling checker
app-text/lesspipe 1.83-r2 1.84_alpha20180414-r2 99999999: Wolfgang Friebel's preprocessor for sys-apps/less. Disable by appending colon
app-text/mbtpdfasm 1.0.28-r1: Tool to assemble/merge, extract information from, and update the metadata in PDF
-app-text/podofo 0.9.6_pre20171027: PoDoFo is a C++ library to work with the PDF file format
+app-text/podofo 0.9.6_p20180715: PoDoFo is a C++ library to work with the PDF file format
app-text/psjoin 0.3: concatenate postscript files. From new PostScript Utilities
app-text/stardict 3.0.6-r4 4.0.0_pre20160518-r2: A international dictionary supporting fuzzy and glob style matching
dev-cpp/cpplint 99999999: The google styleguide together with cpplint and an emacs file
@@ -102,7 +102,7 @@ sys-apps/paxopen 1.2: A wrapper script to set PAX kernel variables to an insecur
sys-apps/schedule 8.0: script to schedule jobs in a multiuser multitasking environment
sys-apps/starter 3.0: POSIX shell script and function to schedule commands
sys-block/parted 2.4-r2: Create, destroy, resize, check, copy partitions and file systems
-sys-block/zram-init 7.1: Scripts to support compressed swap devices or ramdisks with zram
+sys-block/zram-init 7.1-r1: Scripts to support compressed swap devices or ramdisks with zram
sys-boot/grub-cfg-mv 1.5: A grub.cfg library/example for GRUB2
sys-fs/emount 3.0.4: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
sys-fs/squash_dir 13.14: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
diff --git a/sys-block/zram-init/zram-init-7.1.ebuild b/sys-block/zram-init/zram-init-7.1-r1.ebuild
index 723c1285..d288c49b 100644
--- a/sys-block/zram-init/zram-init-7.1.ebuild
+++ b/sys-block/zram-init/zram-init-7.1-r1.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-RESTRICT="mirror"
inherit readme.gentoo-r1 systemd
DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
@@ -11,7 +10,7 @@ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
IUSE=""
RDEPEND=">=app-shells/push-2.0-r2