summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-08-21 18:16:15 +0200
committerMartin Väth <martin@mvath.de>2017-08-21 18:16:15 +0200
commit8bc18a0c2361049ae954357ac916236a5ff96ad1 (patch)
tree0159ee52e6a8b679a6e5ef0917f9363a0f703bd3
parentapp-portage/eix: Alpha version bump. Wrapper for eix-functions.sh (diff)
downloadmv-8bc18a0c2361049ae954357ac916236a5ff96ad1.tar.gz
mv-8bc18a0c2361049ae954357ac916236a5ff96ad1.tar.bz2
mv-8bc18a0c2361049ae954357ac916236a5ff96ad1.zip
app-portage/eix: Version bump
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.33.0.ebuild (renamed from app-portage/eix/eix-0.32.10.ebuild)59
-rw-r--r--metadata/pkg_desc_index2
3 files changed, 56 insertions, 7 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 30f505e7..f14b595e 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,2 @@
-DIST eix-0.32.10.tar.xz 600120 SHA256 4ecd6ed7e5bb8859c5e5548265e622bffd19800c889d49e75c0bad556830c5da
+DIST eix-0.33.0.tar.xz 610600 SHA256 18e4f195d465a0fbecaf44c49d5ea6e63e14bdafe8aa7d32682f9f369ee648c2
DIST eix-0.33.0_alpha1.tar.gz 668583 SHA256 b7a240a97df25ca03cf63654c8136c1e52e0263c3a21bb126f19892fb2768ce2
diff --git a/app-portage/eix/eix-0.32.10.ebuild b/app-portage/eix/eix-0.33.0.ebuild
index 5eef76dd..0321969e 100644
--- a/app-portage/eix/eix-0.32.10.ebuild
+++ b/app-portage/eix/eix-0.33.0.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
+RESTRICT="mirror"
PLOCALES="de ru"
-inherit bash-completion-r1 l10n tmpfiles
+inherit bash-completion-r1 l10n meson_optional tmpfiles
DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
+IUSE="debug +dep doc +meson nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
BOTHDEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
@@ -21,6 +21,10 @@ RDEPEND="${BOTHDEPEND}
>=app-shells/push-2.0-r2
>=app-shells/quoter-3.0-r2"
DEPEND="${BOTHDEPEND}
+ meson? (
+ >=dev-util/meson-0.41.0
+ >=dev-util/ninja-1.7.2
+ )
app-arch/xz-utils
nls? ( sys-devel/gettext )"
@@ -36,7 +40,31 @@ src_prepare() {
}
src_configure() {
- econf \
+ local emesonargs
+ emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
+ -Dsqlite=$(usex sqlite true false) \
+ -Dextra-doc=$(usex doc true false) \
+ -Dnls=$(usex nls true false) \
+ -Dseparate-tools=$(usex tools true false) \
+ -Dsecurity=$(usex security true false) \
+ -Doptimization=$(usex optimization true false) \
+ -Dstrong-secutiry=$(usex strong-security true false) \
+ -Dstrong-optimization=$(usex strong-optimization true false) \
+ -Ddebugging=$(usex debug true false) \
+ -Dswap-remote=$(usex swap-remote true false) \
+ -Dalways-accept-keywords=$(usex prefix true false) \
+ -Ddep-default=$(usex dep true false) \
+ -Drequired-use-default=$(usex required-use true false) \
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
+ -Dportage-rootpath="${ROOTPATH}" \
+ -Deprefix-default="${EPREFIX}"
+ )
+ if use meson; then
+ meson_src_configure
+ else
+ econf \
$(use_with sqlite) \
$(use_with doc extra-doc) \
$(use_enable nls) \
@@ -53,10 +81,31 @@ src_configure() {
--with-zsh-completion \
--with-portage-rootpath="${ROOTPATH}" \
--with-eprefix-default="${EPREFIX}"
+ fi
+}
+
+src_compile() {
+ if use meson; then
+ meson_src_compile
+ else
+ default
+ fi
+}
+
+src_test() {
+ if use meson; then
+ meson_src_test
+ else
+ default
+ fi
}
src_install() {
- default
+ if use meson; then
+ meson_src_install
+ else
+ default
+ fi
dobashcomp bash/eix
dotmpfiles tmpfiles.d/eix.conf
}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 9cc16bd6..2fc38a92 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -21,7 +21,7 @@ app-emacs/mv_emacs 1.3: (X)Emacs extensions: block support, macrorecorder, verif
app-emacs/po-mode 0.19.8.1-r1: Major mode for GNU gettext PO files
app-eselect/eselect-net 0.2: eselect module for managing network open-rc service configurations
app-misc/knapsack 7.2-r1: A fast solver for the 0/1-knapsack problem with multiple knapsacks
-app-portage/eix 0.32.10 0.33.0_alpha1 99999999: Search and query ebuilds
+app-portage/eix 0.33.0_alpha1 0.33.0 99999999: Search and query ebuilds
app-portage/etcat 1.0.1 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 4.0.0: find cruft files not managed by portage
app-portage/gentoolkit 0.4.0-r1 9999: Collection of administration scripts for Gentoo