summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <mvath@google.com>2019-08-31 20:36:27 +0200
committerMartin Väth <mvath@google.com>2019-08-31 20:36:27 +0200
commita1b511cd49ce8455e40f1f23286538b91d001e8a (patch)
tree96c95ca4fe2dadd84e73f6363365a09be86a0b3c
parentsys-fs/squashfs-tools: Version bump (diff)
downloadmv-a1b511cd49ce8455e40f1f23286538b91d001e8a.tar.gz
mv-a1b511cd49ce8455e40f1f23286538b91d001e8a.tar.bz2
mv-a1b511cd49ce8455e40f1f23286538b91d001e8a.zip
avidemux: adapt partially to current gentoo ebuilds
Signed-off-by: Martin Väth <mvath@google.com>
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.7.4-r1.ebuild (renamed from media-libs/avidemux-core/avidemux-core-2.7.4.ebuild)18
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.7.4-r1.ebuild (renamed from media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild)75
-rw-r--r--media-video/avidemux/avidemux-2.7.4-r1.ebuild (renamed from media-video/avidemux/avidemux-2.7.4.ebuild)48
-rw-r--r--metadata/pkg_desc_index6
4 files changed, 75 insertions, 72 deletions
diff --git a/media-libs/avidemux-core/avidemux-core-2.7.4.ebuild b/media-libs/avidemux-core/avidemux-core-2.7.4-r1.ebuild
index d7d581de..de8c9611 100644
--- a/media-libs/avidemux-core/avidemux-core-2.7.4.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-2.7.4-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors and Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-# EAPI=7 causes cmake-utils to apply broken patches
-EAPI=6
-RESTRICT="mirror"
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/mean00/avidemux2.git"
@@ -26,8 +26,7 @@ SLOT="2.7"
IUSE="debug nls nvenc sdl system-ffmpeg vaapi vdpau xv"
# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
-COMMON_DEPEND="
- dev-db/sqlite:3
+DEPEND="dev-db/sqlite:3
nvenc? ( media-video/nvidia_video_sdk )
sdl? ( media-libs/libsdl:0 )
system-ffmpeg? ( >=virtual/ffmpeg-9:0[mp3,theora] )
@@ -35,13 +34,12 @@ COMMON_DEPEND="
vdpau? ( x11-libs/libvdpau:0 )
xv? ( x11-libs/libXv:0 )
"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
!<media-libs/avidemux-core-${PV}
!<media-video/avidemux-${PV}
nls? ( virtual/libintl:0 )
"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
+BDEPEND="virtual/pkgconfig
nls? ( sys-devel/gettext )
!system-ffmpeg? ( dev-lang/yasm[nls=] )
"
@@ -93,9 +91,9 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile -j1
+ cmake-utils_src_compile
}
src_install() {
- cmake-utils_src_install -j1
+ cmake-utils_src_install
}
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.7.4-r1.ebuild
index 41063cf4..2292f851 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.7.4.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-2.7.4-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors and Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-# EAPI=7 causes cmake-utils to apply broken patches
-EAPI=6
-RESTRICT="mirror"
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/mean00/avidemux2.git"
@@ -15,7 +15,6 @@ else
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-PYTHON_COMPAT=( python2_7 )
inherit cmake-utils python-single-r1
DESCRIPTION="Plugins for the video editor media-video/avidemux"
@@ -27,60 +26,59 @@ SLOT="2.7"
IUSE="a52 aac aften alsa amr dcaenc debug dts fdk fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx nvenc opengl opus oss pulseaudio qt5 truetype twolame vdpau vorbis vpx x264 x265 xv xvid"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-COMMON_DEPEND="
+DEPEND="
~media-libs/avidemux-core-${PV}:${SLOT}[vdpau?]
~media-video/avidemux-${PV}:${SLOT}[opengl?,qt5?]
- >=dev-lang/spidermonkey-1.5-r2:0=
+ dev-lang/spidermonkey:0=
dev-libs/libxml2:2
- media-libs/a52dec:0
+ media-libs/a52dec
media-libs/libass:0=
- media-libs/libmad:0
- media-libs/libmp4v2:0
+ media-libs/libmad
+ media-libs/libmp4v2
media-libs/libpng:0=
- virtual/libiconv:0
+ virtual/libiconv
aac? (
- >=media-libs/faac-1.29.9.2:0
- media-libs/faad2:0
+ media-libs/faac
+ media-libs/faad2
)
- aften? ( media-libs/aften:0 )
- alsa? ( >=media-libs/alsa-lib-1.0.3b-r2:0 )
- amr? ( media-libs/opencore-amr:0 )
- dcaenc? ( media-sound/dcaenc:0 )
- dts? ( media-libs/libdca:0 )
- fdk? ( media-libs/fdk-aac:0 )
+ aften? ( media-libs/aften )
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ dcaenc? ( media-sound/dcaenc )
+ dts? ( media-libs/libdca )
+ fdk? ( media-libs/fdk-aac:0= )
fontconfig? ( media-libs/fontconfig:1.0 )
- fribidi? ( dev-libs/fribidi:0 )
+ fribidi? ( dev-libs/fribidi )
jack? (
- media-sound/jack-audio-connection-kit:0
- libsamplerate? ( media-libs/libsamplerate:0 )
+ media-sound/jack-audio-connection-kit
+ libsamplerate? ( media-libs/libsamplerate )
)
- lame? ( media-sound/lame:0 )
- nvenc? ( amd64? ( media-video/nvidia_video_sdk:0 ) )
- opus? ( media-libs/opus:0 )
- pulseaudio? ( media-sound/pulseaudio:0 )
+ lame? ( media-sound/lame )
+ nvenc? ( amd64? ( media-video/nvidia_video_sdk ) )
+ opus? ( media-libs/opus )
+ pulseaudio? ( media-sound/pulseaudio )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)
truetype? ( media-libs/freetype:2 )
- twolame? ( media-sound/twolame:0 )
- vorbis? ( media-libs/libvorbis:0 )
+ twolame? ( media-sound/twolame )
+ vorbis? ( media-libs/libvorbis )
vpx? ( media-libs/libvpx:0= )
x264? ( media-libs/x264:0= )
x265? ( media-libs/x265:0= )
xv? (
- x11-libs/libX11:0
- x11-libs/libXext:0
- x11-libs/libXv:0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
)
- xvid? ( media-libs/xvid:0 )
+ xvid? ( media-libs/xvid )
"
-DEPEND="${COMMON_DEPEND}
- ${PYTHON_DEPS}
+BDEPEND="${PYTHON_DEPS}
oss? ( virtual/os-headers:0 )
"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
${PYTHON_DEPS}
!<media-libs/avidemux-plugins-${PV}
"
@@ -132,6 +130,7 @@ src_configure() {
-DJACK="$(usex jack)"
-DLAME="$(usex lame)"
-DNVENC="$(usex nvenc)"
+ -DOPENGL="$(usex opengl)"
-DOPUS="$(usex opus)"
-DOSS="$(usex oss)"
-DPULSEAUDIOSIMPLE="$(usex pulseaudio)"
@@ -173,11 +172,7 @@ src_compile() {
src_install() {
for process in ${processes} ; do
- # cmake-utils_src_install doesn't respect BUILD_DIR
- # and there sometimes is a preinstall phase present.
- pushd "${WORKDIR}/${P}_build/${process%%:*}" > /dev/null || die
- grep '^preinstall/fast' Makefile && emake DESTDIR="${D}" preinstall/fast
- grep '^install/fast' Makefile && emake DESTDIR="${D}" install/fast
- popd > /dev/null || die
+ local build="${WORKDIR}/${P}_build/${process%%:*}"
+ BUILD_DIR="${build}" cmake-utils_src_install
done
}
diff --git a/media-video/avidemux/avidemux-2.7.4.ebuild b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
index 35a693a5..05cd184c 100644
--- a/media-video/avidemux/avidemux-2.7.4.ebuild
+++ b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-RESTRICT="mirror"
if [[ ${PV} == *9999* ]] ; then
MY_P="${P}"
@@ -30,6 +29,7 @@ DEPEND="
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
@@ -52,11 +52,34 @@ src_prepare() {
processes="buildCli:avidemux/cli"
if use qt5 ; then
processes+=" buildQt4:avidemux/qt4"
+ # Fix icon name -> avidemux-2.7
+ sed -i -e "/^Icon/ s:${PN}\.png:${PN}-${SLOT}:" appImage/${PN}.desktop || \
+ die "Icon name fix failed."
+
+ # The desktop file is broken. It uses avidemux3_portable instead of avidemux3_qt5
+ sed -i -re '/^Exec/ s:(avidemux3_)portable:\1qt5:' appImage/${PN}.desktop || \
+ die "Desktop file fix failed."
+
+ # QA warnings: missing trailing ';' and 'Application' is deprecated.
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' appImage/${PN}.desktop || \
+ die "Desktop file fix failed."
+
+ # Now rename the desktop file to not collide with 2.6.
+ mv appImage/${PN}.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."
fi
for process in ${processes} ; do
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
done
+
+ # Remove "Build Option" dialog because it doesn't reflect
+ # what the GUI can or has been built with. (Bug #463628)
+ sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || \
+ die "Couldn't remove \"Build Option\" dialog."
+
+ # Fix underlinking with gold
+ sed -i -e 's/{QT_QTGUI_LIBRARY}/{QT_QTGUI_LIBRARY} -lXext/' \
+ avidemux/common/ADM_render/CMakeLists.txt || die
}
src_configure() {
@@ -72,6 +95,7 @@ src_configure() {
-DGETTEXT="$(usex nls)"
-DSDL="$(usex sdl)"
-DLibVA="$(usex vaapi)"
+ -DOPENGL="$(usex opengl)"
-DVDPAU="$(usex vdpau)"
-DXVIDEO="$(usex xv)"
)
@@ -91,10 +115,6 @@ src_configure() {
local build="${WORKDIR}/${P}_build/${process%%:*}"
CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
done
-
- # Fix underlinking with gold
- sed -i -e 's/{QT_QTGUI_LIBRARY}/{QT_QTGUI_LIBRARY} -lXext/' \
- avidemux/common/ADM_render/CMakeLists.txt || die
}
src_compile() {
@@ -117,20 +137,10 @@ src_install() {
BUILD_DIR="${build}" cmake-utils_src_install
done
- if [[ -f "${ED}"/usr/bin/avidemux3_cli ]] ; then
- fperms +x /usr/bin/avidemux3_cli
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_jobs ]] ; then
- fperms +x /usr/bin/avidemux3_jobs
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_qt5 ]] ; then
- fperms +x /usr/bin/avidemux3_qt5
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_jobs_qt5 ]] ; then
- fperms +x /usr/bin/avidemux3_jobs_qt5
+ if use qt5; then
+ cd "${S}" || die "Can't enter source folder"
+ newicon ${PN}_icon.png ${PN}-${SLOT}.png
+ domenu ${PN}-${SLOT}.desktop
fi
}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index ffb45c64..cddc43ca 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -75,12 +75,12 @@ games-rpg/m5figur-mv 4.1.4: LaTeX2e character sheet layout for the Midgard Role
mail-client/alpine 2.00-r7 2.21.1-r1: alpine is an easy to use text-based based mail and news client
media-gfx/ipe 7.2.7: Drawing editor for creating figures in PDF or PS formats
media-gfx/pqiv 2.11: powerful GTK based command-line image viewer with a minimal UI
-media-libs/avidemux-core 2.7.4: Core libraries for simple video cutting, filtering and encoding tasks
-media-libs/avidemux-plugins 2.7.4: Plugins for the video editor media-video/avidemux
+media-libs/avidemux-core 2.7.4-r1: Core libraries for simple video cutting, filtering and encoding tasks
+media-libs/avidemux-plugins 2.7.4-r1: Plugins for the video editor media-video/avidemux
media-tv/nvtv 0.4.7-r3: TV-Out for NVidia cards
media-tv/sundtek-tv 190731.173415: Sundtek MediaTV Pro III Drivers
media-tv/w_scan 20170107-r1: Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies
-media-video/avidemux 2.7.4: Video editor designed for simple cutting, filtering and encoding tasks
+media-video/avidemux 2.7.4-r1: Video editor designed for simple cutting, filtering and encoding tasks
media-video/avinfo 1.0_alpha15_p1: Utility for displaying AVI information
media-video/video-mv 16.2: Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder
net-dialup/accounting 1.60.45.3.1-r1: Give statistics about dialup connections. Originally part of SuSE's smpppd