summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2020-10-03 11:11:37 +0200
committerMartin Väth <martin@mvath.de>2020-10-03 11:11:37 +0200
commitbf5053e69ae16a78c676901d089e19fd1c7b9214 (patch)
tree75c4e4cfff75cc2e514f05e950d6584f84ecd40d
parentvirtual/emacs -> app-editors/emacs (diff)
downloadmv-bf5053e69ae16a78c676901d089e19fd1c7b9214.tar.gz
mv-bf5053e69ae16a78c676901d089e19fd1c7b9214.tar.bz2
mv-bf5053e69ae16a78c676901d089e19fd1c7b9214.zip
app-portage/eix: Alpha version bump
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.34.10_alpha20201003.ebuild178
-rw-r--r--app-portage/eix/eix-99999999.ebuild2
-rw-r--r--metadata/pkg_desc_index2
4 files changed, 181 insertions, 2 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index e7427ae5..f8dd6512 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1 +1,2 @@
+DIST eix-0.34.10_alpha20201003.tar.gz 688522 SHA512 c32b61c9997cdcd72fbcb5c8c31f3077d8dba18274b26f147769114a041b0da65eb87c7d7ecec5621877d9c32293b879d847d0517def0df0ed19e29f3b650775
DIST eix-0.34.9.tar.xz 629672 SHA512 5cb00c813bc31971a0cfd77cae0c676040d33f24963cb241274918d2e381956ca949593e0637d81040a9751db0a925552913188cc25ada9a90c6007c31f72e43
diff --git a/app-portage/eix/eix-0.34.10_alpha20201003.ebuild b/app-portage/eix/eix-0.34.10_alpha20201003.ebuild
new file mode 100644
index 00000000..11e16f8c
--- /dev/null
+++ b/app-portage/eix/eix-0.34.10_alpha20201003.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2020 Martin V\"ath and others
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WANT_LIBTOOL=none
+AUTOTOOLS_AUTO_DEPEND=no
+MESON_AUTO_DEPEND=no
+inherit autotools bash-completion-r1 meson tmpfiles
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="83e6f90231183f8b141a2bab4f665adab7d73cb9"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+
+LICENSE="GPL-2"
+SLOT="0"
+PLOCALES="de ru"
+IUSE="cpu_flags_x86_sse2 debug +dep doc +jumbo-build"
+for i in ${PLOCALES}; do
+ IUSE+=" l10n_${i}"
+done
+IUSE+=" +meson nls optimization +protobuf +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
+
+DEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${DEPEND}
+ >=app-shells/push-3.1
+ >=app-shells/quoter-4.1"
+BDEPEND="meson? (
+ >=dev-util/meson-0.41.0
+ >=dev-util/ninja-1.7.2
+ strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
+ nls? ( sys-devel/gettext )
+ )
+ !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )
+ protobuf? ( dev-libs/protobuf:= )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache="${EROOT}var/cache/${PN}"
+ test -f "${old_cache}" && rm -f -- "${old_cache}"
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ default
+ use meson || {
+ eautopoint
+ eautoreconf
+ }
+}
+
+src_configure() {
+ local i
+ export LINGUAS=
+ for i in ${PLOCALES}; do
+ use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
+ done
+ if use meson; then
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
+ $(meson_use jumbo-build)
+ $(meson_use sqlite)
+ $(meson_use protobuf)
+ $(meson_use doc extra-doc)
+ $(meson_use nls)
+ $(meson_use tools separate-tools)
+ $(meson_use security)
+ $(meson_use optimization normal-optimization)
+ $(meson_use strong-security)
+ $(meson_use strong-optimization)
+ $(meson_use debug debugging)
+ $(meson_use swap-remote)
+ $(meson_use prefix always-accept-keywords)
+ $(meson_use cpu_flags_x86_sse2 sse2)
+ $(meson_use dep dep-default)
+ $(meson_use required-use required-use-default)
+ $(meson_use src-uri src-uri-default)
+ $(usex usr-portage -Dportdir-default=/usr/portage '')
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
+ -Dportage-rootpath="${ROOTPATH}"
+ -Deprefix-default="${EPREFIX}"
+ )
+ if use prefix; then
+ emesonarge+=(
+ -Deix-user=
+ -Deix-uid=-1
+ )
+ fi
+ meson_src_configure
+ else
+ local myconf=(
+ $(use_enable jumbo-build)
+ $(use_with sqlite)
+ $(use_with protobuf)
+ $(use_with doc extra-doc)
+ $(use_enable nls)
+ $(use_enable tools separate-tools)
+ $(use_enable security)
+ $(use_enable optimization)
+ $(use_enable strong-security)
+ $(use_enable strong-optimization)
+ $(use_enable debug debugging)
+ $(use_enable swap-remote)
+ $(use_with prefix always-accept-keywords)
+ $(use_with cpu_flags_x86_sse2 sse2)
+ $(use_with dep dep-default)
+ $(use_with required-use required-use-default)
+ $(use_with src-uri src-uri-default)
+ $(use_with usr-portage portdir-default /usr/portage)
+ --with-zsh-completion
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+ )
+ if use prefix; then
+ myconf+=(
+ --with-eix-user=
+ --with-eix-uid=-1
+ )
+ fi
+ econf "${myconf[@]}"
+ fi
+}
+
+src_compile() {
+ if use meson; then
+ meson_src_compile
+ else
+ default
+ fi
+}
+
+src_test() {
+ if use meson; then
+ meson_src_test
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use meson; then
+ meson_src_install
+ else
+ default
+ fi
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+ use doc && dodoc src/output/eix.proto
+}
+
+pkg_postinst() {
+ local obs="${EROOT}var/cache/eix.previous"
+ if test -f "${obs}"; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+ tmpfiles_process eix.conf
+}
+
+pkg_postrm() {
+ if [ -z "${REPLACED_BY_VERSION}" ]; then
+ rm -rf -- "${EROOT}var/cache/${PN}"
+ fi
+}
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 3c41634e..11e16f8c 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -17,7 +17,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="eaa44b984dcdb4fe9499d6b71735bac4a30899bd"
+ EGIT_COMMIT="83e6f90231183f8b141a2bab4f665adab7d73cb9"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 4a22627f..ac5eb290 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -23,7 +23,7 @@ app-misc/knapsack 7.3: A fast solver for the 0/1-knapsack problem with multiple
app-misc/machine-learning-mv 1.3: Some machine learning experiments
app-misc/resolve-march-native 0.9.4: Resolve GCC flag -march=native
app-portage/changelog-gitrepo 1.1: Create ChangeLog data for gentoo repositories from git
-app-portage/eix 0.34.9 99999999: Search and query ebuilds
+app-portage/eix 0.34.9 0.34.10_alpha20201003 99999999: Search and query ebuilds
app-portage/etcat 1.0.2 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 5.2: find cruft files not managed by portage
app-portage/getdelta 0.7.9-r2: dynamic deltup client