summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-02-11 23:04:53 +0100
committerMartin Väth <martin@mvath.de>2017-02-11 23:04:53 +0100
commite3a89905ea9583dd7d2e4baaf9fc4b9cfef3bfdd (patch)
treeb3273c5f0de293687e43aeb96d1c0cc72d8f7867
parentVersion bump to be newer than the broken versions in the gentoo tree (diff)
downloadmv-e3a89905ea9583dd7d2e4baaf9fc4b9cfef3bfdd.tar.gz
mv-e3a89905ea9583dd7d2e4baaf9fc4b9cfef3bfdd.tar.bz2
mv-e3a89905ea9583dd7d2e4baaf9fc4b9cfef3bfdd.zip
games-board/chessproblem: New ebuild
-rw-r--r--games-board/chessproblem/Manifest1
-rw-r--r--games-board/chessproblem/chessproblem-1.1.ebuild42
-rw-r--r--games-board/chessproblem/metadata.xml21
-rw-r--r--profiles/use.local.desc3
4 files changed, 67 insertions, 0 deletions
diff --git a/games-board/chessproblem/Manifest b/games-board/chessproblem/Manifest
new file mode 100644
index 00000000..e07c5c41
--- /dev/null
+++ b/games-board/chessproblem/Manifest
@@ -0,0 +1 @@
+DIST chessproblem-1.1.tar.gz 34773 SHA256 a2bb6a184b6d2dbe2efaa4d23f0c26e7f54a6c9afefa703fb9d104d66f04b080
diff --git a/games-board/chessproblem/chessproblem-1.1.ebuild b/games-board/chessproblem/chessproblem-1.1.ebuild
new file mode 100644
index 00000000..05bb690a
--- /dev/null
+++ b/games-board/chessproblem/chessproblem-1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+WANT_LIBTOOL=none
+AT_NOELIBTOOLIZE=yes
+inherit autotools vcs-snapshot
+
+DESCRIPTION="Find solutions of chess problems (mate, selfmate, and helpmate) with cooks"
+HOMEPAGE="https://github.com/vaeth/chessproblem/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug optimization strong-optimization"
+
+src_prepare() {
+ if use prefix
+ then set --
+ else set -- -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"'
+ fi
+ sed -e 's!\./chessproblem!chessproblem!' \
+ "${@}" -- contrib/test.pl >test.pl || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable optimization) \
+ $(use_enable strong-optimization)
+}
+
+src_install() {
+ default
+ exeinto "/usr/share/doc/${PF}/"
+ doexe test.pl
+ docompress -x "/usr/share/doc/${PF}/test.pl"
+}
diff --git a/games-board/chessproblem/metadata.xml b/games-board/chessproblem/metadata.xml
new file mode 100644
index 00000000..0a1f21fc
--- /dev/null
+++ b/games-board/chessproblem/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/chessproblem</remote-id>
+ </upstream>
+ <use>
+ <flag name="debug">Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.</flag>
+ <flag name="optimization">Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS</flag>
+ <flag name="strong-optimization">Adds several more agressive CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions. Absense of this USE flag does not strip user's *FLAGS</flag>
+ </use>
+</pkgmetadata>
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 1933cab2..5c1b26fe 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -153,6 +153,9 @@ app-text/stardict:wikiparse - Enable plugin to parse dictionaries in wikimedia f
app-text/stardict:wordnet - Enable wordnet plugin to find similar English words using lexical database
app-text/stardict:xdxfparse - Enable plugin to parse dictionaries in xdxf (XML Dictionary eXchange Format)
app-text/stardict:youdaodict - Enable youdao.com network plugin (for Chinese language)
+games-board/chessproblem:debug - Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.
+games-board/chessproblem:optimization - Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS
+games-board/chessproblem:strong-optimization - Adds several more agressive CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions. Absense of this USE flag does not strip user's *FLAGS
games-emulation/xmame:bundled-libs - Use bundled version of dev-libs/expat
games-emulation/xmame:net - Add network support
games-emulation/xmess:bundled-libs - Use bundled version of dev-libs/expat