summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-04-13 18:34:37 +0200
committerMartin Väth <martin@mvath.de>2018-04-13 18:34:37 +0200
commitfaabbe50895648c48d350e86fb1fd4a68309c022 (patch)
tree5fc8b87bb4a9a38dd9b52a2e09ee063f095d1a43
parentdev-util/replacer: Version bump (diff)
downloadmv-faabbe50895648c48d350e86fb1fd4a68309c022.tar.gz
mv-faabbe50895648c48d350e86fb1fd4a68309c022.tar.bz2
mv-faabbe50895648c48d350e86fb1fd4a68309c022.zip
sys-fs/squashfuse: Version bump
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--sys-fs/squashfuse/Manifest2
-rw-r--r--sys-fs/squashfuse/squashfuse-0.1.103.ebuild (renamed from sys-fs/squashfuse/squashfuse-0.1.102.ebuild)15
3 files changed, 11 insertions, 8 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 9819a879..ab78c6c9 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -101,7 +101,7 @@ sys-fs/aufs-util 99999999: Userspace tools for aufs
sys-fs/emount 3.0.4: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
sys-fs/squash_dir 13.14: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-fs/squashfs-tools 4.3.1_alpha20171129-r1 99999999-r1: Tool for creating compressed filesystem type squashfs
-sys-fs/squashfuse 0.1.102: FUSE filesystem to mount squashfs archives
+sys-fs/squashfuse 0.1.103: FUSE filesystem to mount squashfs archives
sys-fs/squashmount 16.1.0 19.0.2: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-kernel/kccmp 0.3-r1: A simple tool for comparing two linux kernel .config files
sys-kernel/kernel 4.5: A POSIX shell script to compile the kernel with user permissions
diff --git a/sys-fs/squashfuse/Manifest b/sys-fs/squashfuse/Manifest
index 544682ed..e515fde1 100644
--- a/sys-fs/squashfuse/Manifest
+++ b/sys-fs/squashfuse/Manifest
@@ -1 +1 @@
-DIST squashfuse-0.1.102.tar.gz 58575 SHA512 82da76ed48e63b50bda26cab9d62a79ea36d807df5f2c40ac3f180d62c8e89c7cc374d0a702b7136bec3e4f0f7895079f48bb53d701631eb717291e5cb54b372
+DIST squashfuse-0.1.103.tar.gz 58729 SHA512 f5b671661ede6bbb4e20562113812a1326d2c450e1427d48a5e8d8e71ba4c47554a44d222f85919162270cca513c2c583af9ef7e0c53693baa926347b9a543b2
diff --git a/sys-fs/squashfuse/squashfuse-0.1.102.ebuild b/sys-fs/squashfuse/squashfuse-0.1.103.ebuild
index ab104ad3..9fe394d6 100644
--- a/sys-fs/squashfuse/squashfuse-0.1.102.ebuild
+++ b/sys-fs/squashfuse/squashfuse-0.1.103.ebuild
@@ -22,7 +22,7 @@ esac
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lz4 lzma lzo +zlib zstd"
+IUSE="lz4 lzma lzo static-libs +zlib zstd"
REQUIRED_USE="|| ( lz4 lzma lzo zlib zstd )"
COMMON_DEPEND="
@@ -43,11 +43,14 @@ src_prepare() {
}
src_configure() {
- filter-flags -flto* -fwhole-program -fno-common
- econf \
- $(use lz4 || echo --without-lz4) \
- $(use lzma || echo --without-xz) \
- $(use lzo || echo --without-lzo) \
+ filter-flags '-flto*' -fwhole-program -fno-common
+ local myconf=(
+ $(use lz4 || echo --without-lz4)
+ $(use lzma || echo --without-xz)
+ $(use lzo || echo --without-lzo)
$(use zlib || echo --without-zlib)
$(use zstd || echo --without-zstd)
+ $(use static-libs || echo --disable-static)
+ )
+ econf "${myconf[@]}"
}