summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-09-05 20:03:32 +0200
committerMartin Väth <martin@mvath.de>2016-09-05 20:03:32 +0200
commit40bb7e95a46ab4648a97866adb07471ef3bed38c (patch)
tree1eddbefbe4945168c4d61ca43d3e198a648c3cda /app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild
parentapp-accessibility/gespeaker: Fix python dep. First gtk:3 version (diff)
downloadmv-40bb7e95a46ab4648a97866adb07471ef3bed38c.tar.gz
mv-40bb7e95a46ab4648a97866adb07471ef3bed38c.tar.bz2
mv-40bb7e95a46ab4648a97866adb07471ef3bed38c.zip
app-accessibility/gespeaker: Fix shebang patching broken in previous commit
Diffstat (limited to 'app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild')
-rw-r--r--app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild b/app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild
new file mode 100644
index 00000000..25d5d207
--- /dev/null
+++ b/app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A GTK+ frontend for espeak"
+HOMEPAGE="http://www.muflone.com/gespeaker/english/index.html"
+SRC_URI="https://github.com/muflone/gespeaker/releases/download/${PV}/${P}.tar.gz
+ http://www.muflone.com/resources/gespeaker/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+
+IUSE="linguas_ar linguas_bg linguas_de linguas_en linguas_es linguas_fo linguas_fr linguas_it linguas_pl linguas_tr linguas_vi"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="app-accessibility/espeak
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
+ -- "${S}/setup.py" "${S}/src/gespeaker.py" || die
+ python_setup 'python2*'
+ python_fix_shebang "${S}"
+ sed -i \
+ -e 's!share/doc/gespeaker/dbus!share/gtk-doc/gspeaker!' \
+ -e "s!share/doc/gespeaker!share/doc/${PF}!" \
+ -- "${S}/setup.py" || die
+ sed -i \
+ -e 's!env python gespeaker\.py!./gespeaker.py!' \
+ -- "${S}/gespeaker" || die
+ eapply_user
+}