summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-01-28 18:30:41 +0100
committerMartin Väth <martin@mvath.de>2018-01-28 18:30:41 +0100
commit5142824b9d50d8e69bcfc80a59f615e2dc14d7b9 (patch)
tree86816f60511188110da713b0b6a8b17814ef994b /app-admin/checksec/checksec-1.7.5.ebuild
parentwww-plugins/stylus: Version bump (diff)
downloadmv-5142824b9d50d8e69bcfc80a59f615e2dc14d7b9.tar.gz
mv-5142824b9d50d8e69bcfc80a59f615e2dc14d7b9.tar.bz2
mv-5142824b9d50d8e69bcfc80a59f615e2dc14d7b9.zip
app-admin/checksec: Remove since gentoo version also disables auto-update
Diffstat (limited to 'app-admin/checksec/checksec-1.7.5.ebuild')
-rw-r--r--app-admin/checksec/checksec-1.7.5.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-admin/checksec/checksec-1.7.5.ebuild b/app-admin/checksec/checksec-1.7.5.ebuild
deleted file mode 100644
index 76cc7f89..00000000
--- a/app-admin/checksec/checksec-1.7.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN=${PN}.sh
-DESCRIPTION="Tool to check properties of executables (e.g. ASLR/PIE, RELRO, PaX, Canaries)"
-HOMEPAGE="https://github.com/slimm609/checksec.sh"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test update"
-DEPEND="test? ( dev-python/demjson dev-libs/libxml2 )"
-
-case ${PV} in
-99999999*)
- EGIT_REPO_URI="https://github.com/slimm609/${MY_PN}.git"
- inherit git-r3
- PROPERTIES="live"
- KEYWORDS=""
- SRC_URI="";;
-*)
- RESTRICT="mirror"
- SRC_URI="https://github.com/slimm609/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/${MY_PN}-${PV}
-esac
-
-DOCS=( ChangeLog README.md )
-
-src_prepare() {
- if ! use update
- then sed -i -e '/--update/d' extras/zsh/_${PN} || die
- sed -i -e 's/^\([ ]*pkg_release=\)false/\1true/' ${PN} || die
- fi
- eapply_user
-}
-
-src_install() {
- dobin ${PN}
- insinto /usr/share/zsh/site-functions
- doins extras/zsh/_${PN}
- einstalldocs
- doman extras/man/*
-}
-
-src_test() {
- cd tests || return 0
- ./test-checksec.sh || die
-}