summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /app-arch/bzwc
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'app-arch/bzwc')
-rw-r--r--app-arch/bzwc/Manifest1
-rw-r--r--app-arch/bzwc/bzwc-2.18.ebuild41
-rw-r--r--app-arch/bzwc/metadata.xml16
3 files changed, 58 insertions, 0 deletions
diff --git a/app-arch/bzwc/Manifest b/app-arch/bzwc/Manifest
new file mode 100644
index 00000000..7df49bcd
--- /dev/null
+++ b/app-arch/bzwc/Manifest
@@ -0,0 +1 @@
+DIST bzwc-2.18.tar.gz 1844 SHA256 59091b3e210b1db89c02147f6efa1ab60e1b591978b14dde9fd3ac11c8bf5ffd SHA512 1479dc4576d5c05427bf06fd227a2eac7fba4b8cdd842cca9f4b3457a0baabe30d1fe4d2df1d958ec9d76d43c767b72e3c557f67349a19a90f3c88a26f0281e2 WHIRLPOOL 05b8da3017a7886dc3f9d1e6c2a29d3649bbd2595a9aefc45670001957c73be5fd82a76c8b5c394dd92f503fecfd0528d7c65aca99831fc9e7a7fa5c83852407
diff --git a/app-arch/bzwc/bzwc-2.18.ebuild b/app-arch/bzwc/bzwc-2.18.ebuild
new file mode 100644
index 00000000..e2227818
--- /dev/null
+++ b/app-arch/bzwc/bzwc-2.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A POSIX shell wrapper for wc, supporting compressed files (xz, lzma, bz2, gz)"
+HOMEPAGE="https://github.com/vaeth/bzwc/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-shells/push"
+DEPEND=""
+
+src_prepare() {
+ local i
+ use prefix || for i in bin/*
+ do test -h "${i}" || \
+ sed -i -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' -- "${i}" \
+ || die
+ done
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}" || ! test -x "${i}"
+ then doins "${i}"
+ else dobin "${i}"
+ fi
+ done
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}
diff --git a/app-arch/bzwc/metadata.xml b/app-arch/bzwc/metadata.xml
new file mode 100644
index 00000000..d8487bbc
--- /dev/null
+++ b/app-arch/bzwc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/bzwc</remote-id>
+ </upstream>
+</pkgmetadata>