summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-01-20 11:29:54 +0100
committerMartin Väth <martin@mvath.de>2018-01-20 11:29:54 +0100
commitf5acfddbc99c4e448043d2cea6478515e0d19350 (patch)
tree062362be893e6e118b90aa08f3f98bc1be227f66 /app-arch
parentmedia-tv/sundtek-tv: Version bump (diff)
downloadmv-f5acfddbc99c4e448043d2cea6478515e0d19350.tar.gz
mv-f5acfddbc99c4e448043d2cea6478515e0d19350.tar.bz2
mv-f5acfddbc99c4e448043d2cea6478515e0d19350.zip
app-arch/brotli: Remove since bump is now in the gentoo repository
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-1.0.2.ebuild69
-rw-r--r--app-arch/brotli/files/brotli-1.0.1-no-rpath.patch19
-rw-r--r--app-arch/brotli/files/brotli-1.0.1-no-static.patch16
-rw-r--r--app-arch/brotli/metadata.xml22
5 files changed, 0 insertions, 127 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
deleted file mode 100644
index 8059ac92..00000000
--- a/app-arch/brotli/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST brotli-1.0.2.tar.gz 23736359 SHA512 b3ec98159e63b4169dea3e958d60d89247dc1c0f78aab27bfffb2ece659fa024df990d410aa15c12b2082d42e3785e32ec248dce2b116c7f34e98bb6337f9fc9
diff --git a/app-arch/brotli/brotli-1.0.2.ebuild b/app-arch/brotli/brotli-1.0.2.ebuild
deleted file mode 100644
index 4823567b..00000000
--- a/app-arch/brotli/brotli-1.0.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-DISTUTILS_OPTIONAL="1"
-
-inherit cmake-utils distutils-r1 flag-o-matic
-
-DESCRIPTION="Generic-purpose lossless compression algorithm"
-HOMEPAGE="https://github.com/google/brotli"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-RDEPEND+=" !<app-arch/archwrap-8"
-
-IUSE="doc python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-LICENSE="MIT python? ( Apache-2.0 )"
-
-DOCS=( README.md CONTRIBUTING.md )
-
-PATCHES=( "${FILESDIR}"/${PN}-1.0.1-no-rpath.patch )
-
-src_prepare() {
- use static-libs || eapply "${FILESDIR}"/${PN}-1.0.1-no-static.patch
- cmake-utils_src_prepare
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_TESTING="$(usex test)"
- )
- cmake-utils_src_configure
- if use python ; then
- filter-flags -fPIE -pie
- distutils-r1_src_configure
- fi
-}
-
-src_compile() {
- cmake-utils_src_compile
- use python && distutils-r1_src_compile
-}
-
-python_test(){
- esetup.py test || die
-}
-
-src_test() {
- cmake-utils_src_test
- use python && distutils-r1_src_test
-}
-
-src_install() {
- cmake-utils_src_install
- use python && distutils-r1_src_install
- use doc && dodoc docs/*.pdf
- doman docs/*.[0-9n]
-}
diff --git a/app-arch/brotli/files/brotli-1.0.1-no-rpath.patch b/app-arch/brotli/files/brotli-1.0.1-no-rpath.patch
deleted file mode 100644
index 2a9f62c5..00000000
--- a/app-arch/brotli/files/brotli-1.0.1-no-rpath.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- 1/CMakeLists.txt
-+++ 1/CMakeLists.txt
-@@ -24,16 +24,6 @@
-
- include(GNUInstallDirs)
-
--# When building shared libraries it is important to set the correct rpath.
--# See https://cmake.org/Wiki/CMake_RPATH_handling#Always_full_RPATH
--set(CMAKE_SKIP_BUILD_RPATH FALSE)
--set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
--set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
--list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_LIBDIR}" isSystemDir)
--if ("${isSystemDir}" STREQUAL "-1")
-- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_LIBDIR}")
--endif()
--
- # Parse version information from common/version.h. Normally we would
- # define these values here and write them out to configuration file(s)
- # (i.e., config.h), but in this case we parse them from
diff --git a/app-arch/brotli/files/brotli-1.0.1-no-static.patch b/app-arch/brotli/files/brotli-1.0.1-no-static.patch
deleted file mode 100644
index ff2bd1bd..00000000
--- a/app-arch/brotli/files/brotli-1.0.1-no-static.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- 1/CMakeLists.txt
-+++ 1/CMakeLists.txt
-@@ -204,13 +204,6 @@
- )
-
- install(
-- TARGETS ${BROTLI_LIBRARIES_CORE_STATIC}
-- ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
-- LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
-- RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
-- )
--
-- install(
- DIRECTORY ${BROTLI_INCLUDE_DIRS}/brotli
- DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
- )
diff --git a/app-arch/brotli/metadata.xml b/app-arch/brotli/metadata.xml
deleted file mode 100644
index 2a38b9ad..00000000
--- a/app-arch/brotli/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
- <maintainer type="person">
- <email>bicatali@gentoo.org</email>
- <name>Sébastien Fabbro</name>
- </maintainer>
- <longdescription>
- Brotli is a generic-purpose lossless compression algorithm that
- compresses data using a combination of a modern variant of the
- LZ77 algorithm, Huffman coding and 2nd order context modeling,
- with a hight compression ratio. It is similar in speed with
- deflate but offers denser compression.
- </longdescription>
- <upstream>
- <remote-id type="github">google/brotli</remote-id>
- </upstream>
-</pkgmetadata>