summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-09-03 14:44:46 +0200
committerMartin Väth <martin@mvath.de>2016-09-03 14:44:46 +0200
commit982db69e8b02d31d242cd00f2a0bc39ebceb39be (patch)
treebd9109ac1e8d4e5426afe0e9de55d5f08e9c35a8 /app-dicts/ispell-de/ispell-de-20160407.ebuild
parentx11-misc/redshift: Copy old from gentoo repo to aovid gtk+3/introspection dep (diff)
downloadmv-982db69e8b02d31d242cd00f2a0bc39ebceb39be.tar.gz
mv-982db69e8b02d31d242cd00f2a0bc39ebceb39be.tar.bz2
mv-982db69e8b02d31d242cd00f2a0bc39ebceb39be.zip
Copy/bump ispell and some libs from gentoo repository to save from removal
Diffstat (limited to 'app-dicts/ispell-de/ispell-de-20160407.ebuild')
-rw-r--r--app-dicts/ispell-de/ispell-de-20160407.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-dicts/ispell-de/ispell-de-20160407.ebuild b/app-dicts/ispell-de/ispell-de-20160407.ebuild
new file mode 100644
index 00000000..b5b8ddf6
--- /dev/null
+++ b/app-dicts/ispell-de/ispell-de-20160407.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+MY_P=igerman98-${PV}
+
+DESCRIPTION="German and Swiss dictionaries for ispell"
+HOMEPAGE="http://j3e.de/ispell/igerman98/"
+SRC_URI="http://j3e.de/ispell/igerman98/dict/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="alpha amd64 hppa mips ppc sparc x86"
+
+DEPEND="app-text/ispell:="
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ for lang in de_DE de_AT de_CH; do
+ emake ispell/${lang}{.aff,.hash}
+ done
+}
+
+src_install () {
+ insinto /usr/$(get_libdir)/ispell
+ for lang in de_DE de_AT de_CH; do
+ doins ispell/${lang}{.aff,.hash}
+ done
+
+ dodoc Documentation/*
+ rm -f -- "${ED}/usr/share/doc/${PF}/GPL"*
+}