summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-03-19 23:33:05 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:38 +0200
commit071cec1ba5446b7380351c74c25150ee3950d291 (patch)
tree1f490fb1569eabdfb583389095e21131b1a0e00d /app-portage/eix
parentBump duckduckgo, getdelta (diff)
downloadmv-071cec1ba5446b7380351c74c25150ee3950d291.tar.gz
mv-071cec1ba5446b7380351c74c25150ee3950d291.tar.bz2
mv-071cec1ba5446b7380351c74c25150ee3950d291.zip
eix: Add USE=swap-remote
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/ChangeLog3
-rw-r--r--app-portage/eix/eix-99999999.ebuild5
-rw-r--r--app-portage/eix/metadata.xml1
3 files changed, 7 insertions, 2 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index d764f7ed..e5dd5a5f 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Mar 2013; Martin Väth <martin@mvath.de>
+ Require >=gettext-0.18.2. Add USE=swap-remote.
+
26 Jan 2013; Martin Väth <martin@mvath.de>
Add IUSE=strong-security
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 7d90cfbb..b51dbc46 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -19,14 +19,14 @@ PROPERTIES="live"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite tools zsh-completion"
+IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools zsh-completion"
RDEPEND="app-shells/push
sqlite? ( >=dev-db/sqlite-3 )
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
clang? ( sys-devel/clang )
- sys-devel/gettext"
+ >=sys-devel/gettext-0.18.2"
pkg_setup() {
case " ${REPLACING_VERSIONS}" in
@@ -49,6 +49,7 @@ src_configure() {
$(use_enable security) $(use_enable optimization) \
$(use_enable strong-security) \
$(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
$(use_with prefix always-accept-keywords) \
$(use_with dep dep-default) \
$(use_with clang nongnu-cxx clang++) \
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index 95965b5a..de246348 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -29,6 +29,7 @@
<flag name="strong-optimization">Adds several more agressive CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions. Absense of this USE flag does not strip user's *FLAGS</flag>
<flag name="strong-security">Add many checks to prevent exploits if eix code has a bug. This will slow down eix considerably. Use only if you are paranoid or have reasons to suspect a bug.</flag>
<flag name="sqlite">Compile in support for portage's sqlite backend; to actually use it you need additional configuration of portage and eix</flag>
+ <flag name="swap-remote">Swap role of remote addresses in eix-remote, making the data from gpo.zugaina.org the first choice.</flag>
<flag name="tools">Create separate binary for script helper tools; useful if they are called extremely often</flag>
</use>
</pkgmetadata>