summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-11-25 18:29:59 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:34 +0200
commit32e86fb27cbb095943dfaf64f728c458944869cb (patch)
tree1032adb655485c5d5a4f455206aa6e6316d32c51 /app-portage/eix
parentBump noscript, stylish, duckduckgo (diff)
downloadmv-32e86fb27cbb095943dfaf64f728c458944869cb.tar.gz
mv-32e86fb27cbb095943dfaf64f728c458944869cb.tar.bz2
mv-32e86fb27cbb095943dfaf64f728c458944869cb.zip
Bump trickyfetch. Update eix. Update checksums
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/eix-99999999.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 1bc35a18..6a3ce43a 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -29,10 +29,22 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
pkg_setup() {
- if has_version "<${CATEGORY}/${PN}-0.25.3"; then
- local eixcache="${EROOT}/var/cache/${PN}"
- ! test -f "${eixcache}" || rm -f -- "${eixcache}"
- fi
+ local i j eixcache
+ for i in ${REPLACING_VERSIONS[*]}
+ do case ${i} in
+ 0.*)
+ j=${i#0.}
+ j=${j%%.*}
+ [ "${j}" -gt 25 ] && continue
+ [ "${j}" -eq 25 ] && {
+ j=${i#0.25.}
+ [ "${j%%.*}" -ge 3 ] && continue
+ }
+ eixcache=${EROOT}/var/cache/${PN}
+ test -f "${eixcache}" && rm -f -- "${eixcache}"
+ break;;
+ esac
+ done
}
src_prepare() {