summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-12-27 18:04:12 +0100
committerMartin Väth <martin@mvath.de>2016-12-27 18:04:12 +0100
commitb0a419f181ce63e99459d31fda837433bc6fbf30 (patch)
tree0536dd69dfb867482ac0365f01d90b43f934b2c0 /app-portage/eix
parentgames-rpg/m5figur-mv: Version bump (diff)
downloadmv-b0a419f181ce63e99459d31fda837433bc6fbf30.tar.gz
mv-b0a419f181ce63e99459d31fda837433bc6fbf30.tar.bz2
mv-b0a419f181ce63e99459d31fda837433bc6fbf30.zip
app-portage/eix: Version bump
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.32.4.ebuild76
-rw-r--r--app-portage/eix/eix-99999999-r1.ebuild4
3 files changed, 77 insertions, 4 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index f74d1c0d..8379cc96 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1 +1,2 @@
DIST eix-0.32.3.tar.xz 590064 SHA256 fc3b8493a765063d0b912ad7b16e4513a0e18a9be28d77e5148f97a9b838a39b
+DIST eix-0.32.4.tar.xz 592284 SHA256 8132be9c496b5b19699c50d9aacd49560ca1f0466e3de4f47b896337f3527fc6
diff --git a/app-portage/eix/eix-0.32.4.ebuild b/app-portage/eix/eix-0.32.4.ebuild
new file mode 100644
index 00000000..5652fc7a
--- /dev/null
+++ b/app-portage/eix/eix-0.32.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="de ru"
+inherit bash-completion-r1 l10n tmpfiles
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0
+ >=app-shells/quoter-3.0"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache="${EROOT}var/cache/${PN}"
+ test -f "${old_cache}" && rm -f -- "${old_cache}"
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ $(use_with sqlite) \
+ $(use_with doc extra-doc) \
+ $(use_enable nls) \
+ $(use_enable tools separate-tools) \
+ $(use_enable security) \
+ $(use_enable optimization) \
+ $(use_enable strong-security) \
+ $(use_enable strong-optimization) \
+ $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ $(use_with required-use required-use-default) \
+ --with-zsh-completion \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+ local obs="${EROOT}var/cache/eix.previous"
+ if test -f "${obs}"; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+ tmpfiles_process eix.conf
+}
+
+pkg_postrm() {
+ if [ -z "${REPLACED_BY_VERSION}" ]; then
+ rm -rf -- "${EROOT}var/cache/${PN}"
+ fi
+}
diff --git a/app-portage/eix/eix-99999999-r1.ebuild b/app-portage/eix/eix-99999999-r1.ebuild
index 843b76c7..279962ca 100644
--- a/app-portage/eix/eix-99999999-r1.ebuild
+++ b/app-portage/eix/eix-99999999-r1.ebuild
@@ -63,10 +63,6 @@ src_install() {
default
dobashcomp bash/eix
dotmpfiles tmpfiles.d/eix.conf
- diropts -m0755
- dodir /var/cache/eix
- # note: portage:portage ownership may be reset to root
- fowners root:portage "${EROOT}var/cache/${PN}"
}
pkg_postinst() {