summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-09-05 10:58:30 +0200
committerMartin Väth <martin@mvath.de>2017-09-05 10:58:30 +0200
commite17b1ea3511eaf6e2e10c6705914e67a21905501 (patch)
tree29462f9e4515a1b0c3384aac91c596937ac6f1b3 /app-portage/eix
parentapp-portage/eix: Turn error check into a warning, only (diff)
downloadmv-e17b1ea3511eaf6e2e10c6705914e67a21905501.tar.gz
mv-e17b1ea3511eaf6e2e10c6705914e67a21905501.tar.bz2
mv-e17b1ea3511eaf6e2e10c6705914e67a21905501.zip
app-portage/eix: alpha and live: Use upstream test for lto plugin
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.33.1_alpha5.ebuild (renamed from app-portage/eix/eix-0.33.1_alpha4.ebuild)32
-rw-r--r--app-portage/eix/eix-99999999.ebuild32
3 files changed, 35 insertions, 31 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 40be63a0..8c750801 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,2 @@
DIST eix-0.33.0.tar.xz 610600 SHA256 18e4f195d465a0fbecaf44c49d5ea6e63e14bdafe8aa7d32682f9f369ee648c2 SHA512 6fd4ca253ee908eb192ee35c4228bea0fa8a04030070b35489bddc639053c2e3f6a2faf32f539ffd2c7d9da0c664ff5f29ac0d732d9a47b6c9976a65dd402de2
-DIST eix-0.33.1_alpha4.tar.gz 670457 SHA256 425946c077b5ef7fd8b6be28203816133e57b144f6eb206e31635dc36b1ebfda SHA512 7998516a6214ea138faa78246e6553ab3ae552959000ff7508580125f618ea0f10694d408de7ec449f66313400847a46f5b1bfe8d5da6b0a87df545b8963bf4b
+DIST eix-0.33.1_alpha5.tar.gz 671212 SHA256 9771ec32d4c2bb94af4d34c344736cd39e820beb3662dbdc9042e620c17be0b1 SHA512 6a713f62b4540e04ab08bf10b40314671597e784816bd9233675d2f9ff8ff38ec5822269d4a52602fb718ae294e9076eb140f0aa733bf0434c565d6b2230afbd
diff --git a/app-portage/eix/eix-0.33.1_alpha4.ebuild b/app-portage/eix/eix-0.33.1_alpha5.ebuild
index ce1f280d..459b5393 100644
--- a/app-portage/eix/eix-0.33.1_alpha4.ebuild
+++ b/app-portage/eix/eix-0.33.1_alpha5.ebuild
@@ -16,7 +16,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="730c42f1b7ca184380d21b78ef1957d94408e19c"
+ EGIT_COMMIT="42cda673cd27b6869f007ba28a7b9161d85723ed"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -42,24 +42,25 @@ DEPEND="${BOTHDEPEND}
!meson? ( ${AUTOTOOLS_DEPEND} )
>=sys-devel/gettext-0.19.6"
+mesonflto() {
+ use meson && use strong-optimization || return 0
+ einfo "Checking whether compiler supports -flto and static archives"
+ bash contrib/meson-flto-test.sh && return
+ eerror "For app-portage/eix[meson strong-optimization] it is necessary"
+ eerror "that your compiler can access static archives with -flto."
+ eerror "This is perhaps not the case on your system:"
+ eerror "A linker lto plugin might be required."
+ eerror "To establish this plugin, execute as root something like"
+ eerror " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " cd /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
+ die "app-portage/eix[meson strong-optimization] requires flto plugin"
+}
+
pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache="${EROOT}var/cache/${PN}"
test -f "${old_cache}" && rm -f -- "${old_cache}"
-
- local i
- if use meson && use strong-optimization
- then for i in /usr/*/binutils-bin/lib/bfd-plugins/liblto_plugin.*
- do test -h "$i" && return
- done
- ewarn "app-portage/eix[meson strong-optimization]' might fail to"
- ewarn "emerge (link) without the linker lto plugin."
- ewarn "To establish this plugin, execute as root something like"
- ewarn " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
- ewarn " cd /usr/*/binutils-bin/lib/bfd-plugins"
- ewarn " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
- ewarn "The * might have to be replaced by your architecture or gcc version"
- fi
}
src_prepare() {
@@ -69,6 +70,7 @@ src_prepare() {
eautopoint
eautoreconf
}
+ mesonflto
}
src_configure() {
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index ce1f280d..459b5393 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -16,7 +16,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="730c42f1b7ca184380d21b78ef1957d94408e19c"
+ EGIT_COMMIT="42cda673cd27b6869f007ba28a7b9161d85723ed"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -42,24 +42,25 @@ DEPEND="${BOTHDEPEND}
!meson? ( ${AUTOTOOLS_DEPEND} )
>=sys-devel/gettext-0.19.6"
+mesonflto() {
+ use meson && use strong-optimization || return 0
+ einfo "Checking whether compiler supports -flto and static archives"
+ bash contrib/meson-flto-test.sh && return
+ eerror "For app-portage/eix[meson strong-optimization] it is necessary"
+ eerror "that your compiler can access static archives with -flto."
+ eerror "This is perhaps not the case on your system:"
+ eerror "A linker lto plugin might be required."
+ eerror "To establish this plugin, execute as root something like"
+ eerror " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " cd /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
+ die "app-portage/eix[meson strong-optimization] requires flto plugin"
+}
+
pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache="${EROOT}var/cache/${PN}"
test -f "${old_cache}" && rm -f -- "${old_cache}"
-
- local i
- if use meson && use strong-optimization
- then for i in /usr/*/binutils-bin/lib/bfd-plugins/liblto_plugin.*
- do test -h "$i" && return
- done
- ewarn "app-portage/eix[meson strong-optimization]' might fail to"
- ewarn "emerge (link) without the linker lto plugin."
- ewarn "To establish this plugin, execute as root something like"
- ewarn " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
- ewarn " cd /usr/*/binutils-bin/lib/bfd-plugins"
- ewarn " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
- ewarn "The * might have to be replaced by your architecture or gcc version"
- fi
}
src_prepare() {
@@ -69,6 +70,7 @@ src_prepare() {
eautopoint
eautoreconf
}
+ mesonflto
}
src_configure() {