summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /app-portage/portage-bashrc-mv
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'app-portage/portage-bashrc-mv')
-rw-r--r--app-portage/portage-bashrc-mv/Manifest1
-rw-r--r--app-portage/portage-bashrc-mv/metadata.xml16
-rw-r--r--app-portage/portage-bashrc-mv/portage-bashrc-mv-13.6.ebuild45
3 files changed, 62 insertions, 0 deletions
diff --git a/app-portage/portage-bashrc-mv/Manifest b/app-portage/portage-bashrc-mv/Manifest
new file mode 100644
index 00000000..bea7a509
--- /dev/null
+++ b/app-portage/portage-bashrc-mv/Manifest
@@ -0,0 +1 @@
+DIST portage-bashrc-mv-13.6.tar.gz 13566 SHA256 73971b99567b292c9d00612959c73f0241ee42fc2d7689b8f6926aa8d4f0121b SHA512 19fc82395e804c708b08e130a2fe8ee896fa9c6fe44ccdeb6dc15bfcabc311a0aac8c18554d13e14172c54a0805c37d36bdd68490d9a93e11f082b49fab2b192 WHIRLPOOL 2c26b743725e4bcd1fa4ed50e635ee60c3464bc4ed670859d7ecd79730deb5227d16ab47a24105d1f78011e7e700e6a8cb49bdac12afb825e245a61302adcabe
diff --git a/app-portage/portage-bashrc-mv/metadata.xml b/app-portage/portage-bashrc-mv/metadata.xml
new file mode 100644
index 00000000..cb260f08
--- /dev/null
+++ b/app-portage/portage-bashrc-mv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/portage-bashrc-mv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/portage-bashrc-mv/portage-bashrc-mv-13.6.ebuild b/app-portage/portage-bashrc-mv/portage-bashrc-mv-13.6.ebuild
new file mode 100644
index 00000000..a112f8df
--- /dev/null
+++ b/app-portage/portage-bashrc-mv/portage-bashrc-mv-13.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="Provide support for /etc/portage/bashrc.d and /etc/portage/package.cflags"
+HOMEPAGE="https://github.com/vaeth/portage-bashrc-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="!<dev-util/ccache-3.2"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dodoc NEWS README
+ exeinto "/usr/share/doc/${PF}"
+ doexe fix-portage-2.2.15
+ docompress -x "/usr/share/doc/${PF}/fix-portage-2.2.15"
+ insinto /etc/portage
+ doins -r bashrc bashrc.d
+ docompress /etc/portage/bashrc.d/README
+}
+
+pkg_postinst() {
+ case ${REPLACING_VERSIONS} in
+ [0-9].*|1[0-2].*)
+ ewarn "Remember to run /usr/share/doc/${PF}/fix-portage-2.2.15"
+ ewarn "as the first command after upgrading to >=portage-2.2.15"
+ ewarn "See NEWS for details";;
+ esac
+ optfeature "improved mask handling" app-portage/eix
+ optfeature "output of expected emerge time" app-portage/portage-utils
+ optfeature "detailed information output in title bar" app-shells/runtitle
+ ! test -d /var/cache/gpo || \
+ ewarn "Obsolete /var/cache/gpo found. Please remove"
+}