summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /app-portage/trickyfetch/trickyfetch-8.7.ebuild
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'app-portage/trickyfetch/trickyfetch-8.7.ebuild')
-rw-r--r--app-portage/trickyfetch/trickyfetch-8.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-portage/trickyfetch/trickyfetch-8.7.ebuild b/app-portage/trickyfetch/trickyfetch-8.7.ebuild
new file mode 100644
index 00000000..1a58aab1
--- /dev/null
+++ b/app-portage/trickyfetch/trickyfetch-8.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="Plugin for FETCHCOMMAND to help organize and cleanup your DISTDIR"
+HOMEPAGE="https://github.com/vaeth/trickyfetch/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ if use prefix
+ then sed -i \
+ -e "s'\\(PATH=.\\)/etc'\\1${EPREFIX}/etc'" \
+ -- "${S}/bin/trickyfetch" || die
+ else sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- "${S}"/bin/* || die
+ fi
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ insinto /etc
+ doins etc/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+ dodoc README
+}
+
+pkg_postinst() {
+ case " ${REPLACING_VERSIONS:-0.}" in
+ ' '[0-7].*)
+ elog "Please adapt /etc/trickyfetch.conf to your needs";;
+ esac
+ optfeature "faster execution" 'app-portage/eix'
+}