summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-10 08:11:05 +0200
committerMartin Väth <martin@mvath.de>2017-07-10 08:11:05 +0200
commit076140811b2689a0e559485b345aa991a8337ad7 (patch)
tree3bf68b863ceb20246266e87aa44e78f6edaf0152 /app-portage
parentwww-plugins/classic-theme-restorer: Version bump (diff)
downloadmv-076140811b2689a0e559485b345aa991a8337ad7.tar.gz
mv-076140811b2689a0e559485b345aa991a8337ad7.tar.bz2
mv-076140811b2689a0e559485b345aa991a8337ad7.zip
Make nonexpensive deps non-optional. Remove corresponding set data
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/logclean/logclean-14.2.0_p1.ebuild8
-rw-r--r--app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild11
-rw-r--r--app-portage/portage-postsyncd-mv/portage-postsyncd-mv-6.0.1.ebuild15
-rw-r--r--app-portage/useflags/useflags-4.1.2.ebuild10
4 files changed, 31 insertions, 13 deletions
diff --git a/app-portage/logclean/logclean-14.2.0_p1.ebuild b/app-portage/logclean/logclean-14.2.0_p1.ebuild
index 0679e9f2..16771099 100644
--- a/app-portage/logclean/logclean-14.2.0_p1.ebuild
+++ b/app-portage/logclean/logclean-14.2.0_p1.ebuild
@@ -14,9 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+# This should really depend on a USE-flag but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND="dev-perl/File-Which"
+
RDEPEND=">=dev-lang/perl-5.8
dev-perl/String-ShellQuote
- || ( >=dev-lang/perl-5.14 virtual/perl-Term-ANSIColor )"
+ || ( >=dev-lang/perl-5.14 virtual/perl-Term-ANSIColor )
+ ${OPTIONAL_RDEPEND}"
# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
src_prepare() {
@@ -36,5 +41,4 @@ src_install() {
pkg_postinst() {
optfeature "faster execution" 'app-portage/eix'
- optfeature "improved compatibility and security" 'dev-perl/File-Which'
}
diff --git a/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild b/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild
index b2b92a72..ae42a959 100644
--- a/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild
+++ b/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,7 +13,13 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="!<dev-util/ccache-3.2"
+
+# This should really depend on a USE-flag but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND="app-shells/runtitle"
+
+RDEPEND="!<dev-util/ccache-3.2
+ ${OPTIONAL_RDEPEND}"
src_install() {
dodoc AUTHORS NEWS README
@@ -34,7 +40,6 @@ pkg_postinst() {
esac
optfeature "improved mask handling" app-portage/eix
optfeature "output of expected emerge time" app-portage/portage-utils
- optfeature "detailed information output in title bar" app-shells/runtitle
! test -d /var/cache/gpo || \
ewarn "Obsolete /var/cache/gpo found. Please remove"
}
diff --git a/app-portage/portage-postsyncd-mv/portage-postsyncd-mv-6.0.1.ebuild b/app-portage/portage-postsyncd-mv/portage-postsyncd-mv-6.0.1.ebuild
index af756231..6543aa6d 100644
--- a/app-portage/portage-postsyncd-mv/portage-postsyncd-mv-6.0.1.ebuild
+++ b/app-portage/portage-postsyncd-mv/portage-postsyncd-mv-6.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,10 +12,17 @@ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND=">=dev-lang/perl-5.6.1"
-# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
IUSE="+portage-utils"
+# These should really depend on USE-flags but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND="dev-perl/File-Which
+dev-perl/String-ShellQuote"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+${OPTIONAL_RDEPEND}"
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+
src_prepare() {
use prefix || {
sed -i \
@@ -91,6 +98,4 @@ pkg_postinst() {
ewarn 'See the new ChangeLog file for details';;
esac
optfeature "faster execution" 'app-portage/eix'
- optfeature "improved compatibility and security" 'dev-perl/File-Which'
- optfeature "improved security" 'dev-perl/String-ShellQuote'
}
diff --git a/app-portage/useflags/useflags-4.1.2.ebuild b/app-portage/useflags/useflags-4.1.2.ebuild
index 513e1336..ab890981 100644
--- a/app-portage/useflags/useflags-4.1.2.ebuild
+++ b/app-portage/useflags/useflags-4.1.2.ebuild
@@ -14,7 +14,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-lang/perl-5.6.1"
+# These should really depend on USE-flags but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND="dev-perl/File-Which
+dev-perl/String-ShellQuote"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ ${OPTIONAL_RDEPEND}"
# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )"
src_prepare() {
@@ -33,6 +39,4 @@ src_install() {
pkg_postinst() {
optfeature "faster execution" 'app-portage/eix'
optfeature "increased security" '>=app-portage/eix-0.27.7'
- optfeature "improved compatibility and security" 'dev-perl/File-Which'
- optfeature "improved security" 'dev-perl/String-ShellQuote'
}