summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-09-25 20:31:28 +0200
committerMartin Väth <martin@mvath.de>2017-09-25 20:31:28 +0200
commit1cabb89ef053ec645f477b350e58f1a86e527c33 (patch)
tree80cd765885dde63a2b257eab9dc94be96f6fb6fb /app-portage
parentapp-arch/brotli: Filter -fPIE -pie when compiling python lib (diff)
downloadmv-1cabb89ef053ec645f477b350e58f1a86e527c33.tar.gz
mv-1cabb89ef053ec645f477b350e58f1a86e527c33.tar.bz2
mv-1cabb89ef053ec645f477b350e58f1a86e527c33.zip
app-portage/portage-bashrc-mv: https://github.com/vaeth/mv-overlay/issues/3
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portage-bashrc-mv/Manifest2
-rw-r--r--app-portage/portage-bashrc-mv/metadata.xml7
-rw-r--r--app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild33
3 files changed, 31 insertions, 11 deletions
diff --git a/app-portage/portage-bashrc-mv/Manifest b/app-portage/portage-bashrc-mv/Manifest
index eb6033d2..eb3c3ffe 100644
--- a/app-portage/portage-bashrc-mv/Manifest
+++ b/app-portage/portage-bashrc-mv/Manifest
@@ -1 +1 @@
-DIST portage-bashrc-mv-14.5.tar.gz 15102 SHA256 55a9a9a7ae05022fb839d173d63157614c8ab1f6dff8acfc5550582538dd18ba
+DIST portage-bashrc-mv-14.5.tar.gz 15102 SHA256 55a9a9a7ae05022fb839d173d63157614c8ab1f6dff8acfc5550582538dd18ba SHA512 7de3b60c8011b12d68684846fc8e98f978aa6cb37c8d597e2693537888e0dea3541eabe820208e5ff13899c163c9c44dec1352a82abef9367aa774cfe4b93d86
diff --git a/app-portage/portage-bashrc-mv/metadata.xml b/app-portage/portage-bashrc-mv/metadata.xml
index 8e9431a9..540d8814 100644
--- a/app-portage/portage-bashrc-mv/metadata.xml
+++ b/app-portage/portage-bashrc-mv/metadata.xml
@@ -13,4 +13,11 @@
<bugs-to>mailto:martin@mvath.de</bugs-to>
<remote-id type="github">vaeth/portage-bashrc-mv</remote-id>
</upstream>
+ <use>
+ <flag name="ccache">Install a script for CCACHE_* variable support. This requires dev-util/ccache</flag>
+ <flag name="cflags">Install a script for /etc/portage/package.cflags support. Requires app-portage/eix for fast parsing</flag>
+ <flag name="localepurge">Install a script to remove unneeded locales. Requires the config files of app-admin/localepurge</flag>
+ <flag name="remove-la">Install a script to remove unneeded .ls files</flag>
+ <flag name="title">Install a script to display the expected merge time. Requires app-portage/portage-utils and app-shells/runtitle</flag>
+ </use>
</pkgmetadata>
diff --git a/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild b/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild
index ae42a959..1ca36382 100644
--- a/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild
+++ b/app-portage/portage-bashrc-mv/portage-bashrc-mv-14.5.ebuild
@@ -3,7 +3,6 @@
EAPI=6
RESTRICT="mirror"
-inherit eutils
DESCRIPTION="Provide support for /etc/portage/bashrc.d and /etc/portage/package.cflags"
HOMEPAGE="https://github.com/vaeth/portage-bashrc-mv/"
@@ -12,14 +11,23 @@ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+ccache +cflags +localepurge +remove-la +title"
-# This should really depend on a USE-flag but must not by policy.
-# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
-OPTIONAL_RDEPEND="app-shells/runtitle"
+# the ccache script would run without dev-util/ccache but would be pointless:
+RDEPEND="ccache? ( >=dev-util/ccache-3.2 )"
-RDEPEND="!<dev-util/ccache-3.2
- ${OPTIONAL_RDEPEND}"
+# The flags script would run without app-portage/eix, but package.cflags
+# parsing would be much slower (and is almost not tested):
+RDEPEND=${RDEPEND}" cflags? ( app-portage/eix )"
+
+# The localepurge script uses the config files from app-admin/localepurge:
+RDEPEND=${RDEPEND}" localepurge? ( app-admin/localepurge )"
+
+# The title script would do nothing without these packages:
+RDEPEND=${RDEPEND}" title? (
+ app-portage/portage-utils
+ app-shells/runtitle
+)"
src_install() {
dodoc AUTHORS NEWS README
@@ -27,8 +35,15 @@ src_install() {
doexe fix-portage-2.2.15
docompress -x "/usr/share/doc/${PF}/fix-portage-2.2.15"
insinto /etc/portage
- doins -r bashrc bashrc.d
+ doins -r bashrc
+ insinto /etc/portage/bashrc.d
+ doins bashrc.d/[a-zA-Z]*
docompress /etc/portage/bashrc.d/README
+ ! use ccache || doins bashrc.d/*ccache*
+ ! use cflags || doins bashrc.d/*flag*
+ ! use localepurge || doins bashrc.d/*locale*purge*
+ ! use remove-la || doins bashrc.d/*remove*la*
+ ! use title || doins bashrc.d/*title*
}
pkg_postinst() {
@@ -38,8 +53,6 @@ pkg_postinst() {
ewarn "as the first command after upgrading to >=portage-2.2.15"
ewarn "See NEWS for details";;
esac
- optfeature "improved mask handling" app-portage/eix
- optfeature "output of expected emerge time" app-portage/portage-utils
! test -d /var/cache/gpo || \
ewarn "Obsolete /var/cache/gpo found. Please remove"
}