summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-04-15 21:00:18 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:47:36 +0200
commitbd582bfb4b4f1b38ed7effb0e65353f9bae30f9c (patch)
tree27fca8ca6840a4fc125774621d98490fead6f32f /app-portage
parentAdd requestpolicy ebuild (diff)
downloadmv-bd582bfb4b4f1b38ed7effb0e65353f9bae30f9c.tar.gz
mv-bd582bfb4b4f1b38ed7effb0e65353f9bae30f9c.tar.bz2
mv-bd582bfb4b4f1b38ed7effb0e65353f9bae30f9c.zip
Add base. Fix stardict compilation
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/getdelta/ChangeLog3
-rw-r--r--app-portage/getdelta/getdelta-0.7.9.ebuild6
-rw-r--r--app-portage/logclean/ChangeLog3
-rw-r--r--app-portage/logclean/logclean-7.7.ebuild2
-rw-r--r--app-portage/portage-bashrc-mv/ChangeLog3
-rw-r--r--app-portage/portage-bashrc-mv/portage-bashrc-mv-10.7.ebuild2
-rw-r--r--app-portage/trickyfetch/ChangeLog3
-rw-r--r--app-portage/trickyfetch/trickyfetch-6.5.ebuild2
-rw-r--r--app-portage/useflags/ChangeLog3
-rw-r--r--app-portage/useflags/useflags-2.6.ebuild2
-rw-r--r--app-portage/world-mv/world-mv-3.6.ebuild3
11 files changed, 25 insertions, 7 deletions
diff --git a/app-portage/getdelta/ChangeLog b/app-portage/getdelta/ChangeLog
index e441a8c5..63c0dbc5 100644
--- a/app-portage/getdelta/ChangeLog
+++ b/app-portage/getdelta/ChangeLog
@@ -4,6 +4,9 @@
*getdelta-0.7.9 (19 Mar 2012)
+ 15 Apr 2012; Martin Väth <martin@mvath.de>
+ Inherit base.
+
19 Mar 2012; Martin Väth <martin@mvath.de>
Upgrade according to version bump in main tree.
diff --git a/app-portage/getdelta/getdelta-0.7.9.ebuild b/app-portage/getdelta/getdelta-0.7.9.ebuild
index 3d2c6b8a..9893b45f 100644
--- a/app-portage/getdelta/getdelta-0.7.9.ebuild
+++ b/app-portage/getdelta/getdelta-0.7.9.ebuild
@@ -3,7 +3,7 @@
# $Header $
EAPI="4"
-inherit eutils
+inherit base
DESCRIPTION="dynamic deltup client"
HOMEPAGE="http://linux01.gwdg.de/~nlissne/"
@@ -17,9 +17,11 @@ S="${WORKDIR}"
RDEPEND="app-portage/deltup
dev-util/bdelta"
+PATCHES=("${FILESDIR}/eapi2.patch")
+
src_prepare() {
- epatch "${FILESDIR}"/eapi2.patch
sed -i -e "s:/bin/sh:/bin/bash:" getdelta.sh || die
+ base_src_prepare
}
src_install() {
diff --git a/app-portage/logclean/ChangeLog b/app-portage/logclean/ChangeLog
index 76837071..7db43367 100644
--- a/app-portage/logclean/ChangeLog
+++ b/app-portage/logclean/ChangeLog
@@ -4,6 +4,9 @@
*logclean-7.7 (07 Jan 2012)
+ 15 Apr 2012; Martin Väth <martin@mvath.de>
+ Inherit base
+
19 Mar 2012; Martin Väth <martin@mvath.de>
Use vcs-snapshot.eclass
diff --git a/app-portage/logclean/logclean-7.7.ebuild b/app-portage/logclean/logclean-7.7.ebuild
index a5ee2d84..d2a17da2 100644
--- a/app-portage/logclean/logclean-7.7.ebuild
+++ b/app-portage/logclean/logclean-7.7.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
RESTRICT="mirror"
-inherit vcs-snapshot
+inherit base vcs-snapshot
DESCRIPTION="Keep only (compressed) logs of installed packages"
HOMEPAGE="https://github.com/vaeth/logclean/"
diff --git a/app-portage/portage-bashrc-mv/ChangeLog b/app-portage/portage-bashrc-mv/ChangeLog
index 6b4319dc..70ef04fd 100644
--- a/app-portage/portage-bashrc-mv/ChangeLog
+++ b/app-portage/portage-bashrc-mv/ChangeLog
@@ -4,6 +4,9 @@
*portage-bashrc-mv-10.7 (08 Apr 2012)
+ 15 Apr 2012; Martin Väth <martin@mvath.de>
+ Inherit base
+
08 Apr 2012; Martin Väth <martin@mvath.de>
Version bump, remove old ebuild.
diff --git a/app-portage/portage-bashrc-mv/portage-bashrc-mv-10.7.ebuild b/app-portage/portage-bashrc-mv/portage-bashrc-mv-10.7.ebuild
index 592c1a72..628ccdd1 100644
--- a/app-portage/portage-bashrc-mv/portage-bashrc-mv-10.7.ebuild
+++ b/app-portage/portage-bashrc-mv/portage-bashrc-mv-10.7.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
RESTRICT="mirror"
-inherit vcs-snapshot
+inherit base vcs-snapshot
DESCRIPTION="Provide support for /etc/portage/bashrc.d and /etc/portage/package.cflags"
HOMEPAGE="https://github.com/vaeth/portage-bashrc-mv/"
diff --git a/app-portage/trickyfetch/ChangeLog b/app-portage/trickyfetch/ChangeLog
index 8553d38b..d0d27f94 100644
--- a/app-portage/trickyfetch/ChangeLog
+++ b/app-portage/trickyfetch/ChangeLog
@@ -4,6 +4,9 @@
*trickyfetch-6.5 (08 Apr 2012)
+ 15 Apr 2012; Martin Väth <martin@mvath.de>
+ Inherit base
+
08 Apr 2012; Martin Väth <martin@mvath.de>
Version bump, remove old ebuild.
diff --git a/app-portage/trickyfetch/trickyfetch-6.5.ebuild b/app-portage/trickyfetch/trickyfetch-6.5.ebuild
index 83e80f0b..cfdcb068 100644
--- a/app-portage/trickyfetch/trickyfetch-6.5.ebuild
+++ b/app-portage/trickyfetch/trickyfetch-6.5.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
RESTRICT="mirror"
-inherit vcs-snapshot
+inherit base vcs-snapshot
DESCRIPTION="Plugin for FETCHCOMMAND to help organize and cleanup your DISTDIR"
HOMEPAGE="https://github.com/vaeth/trickyfetch/"
diff --git a/app-portage/useflags/ChangeLog b/app-portage/useflags/ChangeLog
index 63e512d8..be20aeb1 100644
--- a/app-portage/useflags/ChangeLog
+++ b/app-portage/useflags/ChangeLog
@@ -4,6 +4,9 @@
*useflags-2.6 (08 Jan 2012)
+ 15 Apr 2012; Martin Väth <martin@mvath.de>
+ Inherit base
+
19 Mar 2012; Martin Väth <martin@mvath.de>
Use vcs-snapshot.eclass
diff --git a/app-portage/useflags/useflags-2.6.ebuild b/app-portage/useflags/useflags-2.6.ebuild
index ca20a09a..b07f727a 100644
--- a/app-portage/useflags/useflags-2.6.ebuild
+++ b/app-portage/useflags/useflags-2.6.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
RESTRICT="mirror"
-inherit vcs-snapshot
+inherit base vcs-snapshot
DESCRIPTION="Print or save the current USE-flag state and compare with older versions"
HOMEPAGE="https://github.com/vaeth/useflags/"
diff --git a/app-portage/world-mv/world-mv-3.6.ebuild b/app-portage/world-mv/world-mv-3.6.ebuild
index 52bcc05d..f10bdd17 100644
--- a/app-portage/world-mv/world-mv-3.6.ebuild
+++ b/app-portage/world-mv/world-mv-3.6.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
RESTRICT="mirror"
-inherit vcs-snapshot
+inherit base vcs-snapshot
mPN="${PN%-*}"
DESCRIPTION="Organize your world file and find installed packages or differences to @world"
@@ -20,6 +20,7 @@ RDEPEND=">=sys-apps/portage-2.2"
src_prepare() {
sed -i -e "s'\"\${EPREFIX}\"'\\'${EPREFIX}\\''" "${mPN}" || die
+ base_src_prepare
}
src_install() {