summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-09-20 11:08:42 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:14 +0200
commit7a21abdfd5852198090303e7f05a92fee4100a32 (patch)
treea9c65395065789504a34e2dcb8fc27a2cf5061af /app-shells/auto-fu-zsh
parentBump mv_perl (diff)
downloadmv-7a21abdfd5852198090303e7f05a92fee4100a32.tar.gz
mv-7a21abdfd5852198090303e7f05a92fee4100a32.tar.bz2
mv-7a21abdfd5852198090303e7f05a92fee4100a32.zip
auto-fu-zsh: fix compilation in corner cases. mv_perl: Fix date
Diffstat (limited to 'app-shells/auto-fu-zsh')
-rw-r--r--app-shells/auto-fu-zsh/ChangeLog3
-rw-r--r--app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild4
2 files changed, 6 insertions, 1 deletions
diff --git a/app-shells/auto-fu-zsh/ChangeLog b/app-shells/auto-fu-zsh/ChangeLog
index cc066c71..3e8b7131 100644
--- a/app-shells/auto-fu-zsh/ChangeLog
+++ b/app-shells/auto-fu-zsh/ChangeLog
@@ -4,6 +4,9 @@
*auto-fu-zsh-99999999 (14 Sep 2013)
+ 20 Sep 2014; Martin Väth <martin@mvath.de>:
+ Fix compilation in some corner cases
+
06 Jul 2014; Martin Väth <martin@mvath.de>:
New style github tarball
diff --git a/app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild b/app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild
index 048b95c6..a12dc612 100644
--- a/app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild
+++ b/app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild
@@ -116,7 +116,9 @@ src_prepare() {
src_compile() {
! use compile || mPN="${mPN}" \
- zsh -c 'source ${mPN} && auto-fu-zcompile ${PWD}/${mPN} ${PWD}' || die
+ zsh -c 'setopt extendedglob no_shwordsplit
+source ${mPN}
+auto-fu-zcompile ${PWD}/${mPN} ${PWD}' || die
}
src_install() {