summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /app-shells/command-not-found
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'app-shells/command-not-found')
-rw-r--r--app-shells/command-not-found/Manifest1
-rw-r--r--app-shells/command-not-found/command-not-found-0.4.5.ebuild49
-rw-r--r--app-shells/command-not-found/metadata.xml16
3 files changed, 66 insertions, 0 deletions
diff --git a/app-shells/command-not-found/Manifest b/app-shells/command-not-found/Manifest
new file mode 100644
index 00000000..73ec8857
--- /dev/null
+++ b/app-shells/command-not-found/Manifest
@@ -0,0 +1 @@
+DIST command-not-found-0.4.5.tar.gz 28761 SHA256 891c5a7f2e55e420dd92ce4358d7c2f6028144c92bd522163848345c4c32b914 SHA512 3512ef8618a23416dd0da37ea2ccd40b78e44751b16703b745360345430ce697713a7b781c065536d7fd8b54ca0f4713ce153b2f32f5266b6db222ac2aa23c0b WHIRLPOOL 95e730db83571e6cab799a8c8865117cae74573cb1f2b769fb72e329793643058f6e49c406dd26adc18f63d38b66151a48c06e565382d2c78f864bdb22268fbc
diff --git a/app-shells/command-not-found/command-not-found-0.4.5.ebuild b/app-shells/command-not-found/command-not-found-0.4.5.ebuild
new file mode 100644
index 00000000..77f3273f
--- /dev/null
+++ b/app-shells/command-not-found/command-not-found-0.4.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit cmake-utils eutils flag-o-matic multilib
+
+DESCRIPTION="If a command is not found (bash/zsh), search ARCH database for packages with similar commands"
+HOMEPAGE="https://github.com/metti/command-not-found/"
+SRC_URI="https://github.com/metti/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON="sys-libs/tdb"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ PREFIX=${EPREFIX}
+ filter-flags -fwhole-program
+ sed -i -e 1d -e '2i#! /bin/sh' cnf-cron.in || die
+ sed -i \
+ -e "s!usr/lib!usr/$(get_libdir)!g" \
+ -e "/^INSTALL.*cnf\.sh/,/^INSTALL/{/EXECUTE/d}" \
+ CMakeLists.txt || die
+ sed -i -e "s/function[[:space:]]*\([^[:space:](]*\)[[:space:]]*(/\1(/" \
+ cnf.sh || die
+ epatch_user
+}
+
+src_install() {
+ dodir /var/lib/cnf
+ cmake-utils_src_install
+}
+
+pkg_postrm() {
+ local a
+ if [ -z "${REPLACED_BY_VERSION}" ] && a="${EPREFIX}/var/lib/cnf" && \
+ test -d "${a}"
+ then ewarn "removing now unneeded ${a}"
+ rm -rf -- "${a}"
+ fi
+}
diff --git a/app-shells/command-not-found/metadata.xml b/app-shells/command-not-found/metadata.xml
new file mode 100644
index 00000000..cc0f89f0
--- /dev/null
+++ b/app-shells/command-not-found/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>matthias@maennich.net</email>
+ <name>Matthias Maennich</name>
+ </maintainer>
+ <bugs-to>mailto:matthias@maennich.net</bugs-to>
+ <remote-id type="github">metti/command-not-found</remote-id>
+ </upstream>
+</pkgmetadata>