summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-10-29 20:41:38 +0200
committerMartin Väth <martin@mvath.de>2016-10-29 20:41:38 +0200
commitcc532f094f45a677094f9ff6409d3f39068c184d (patch)
tree767dd5f3c126819b4952812d71810da91b5dd566 /app-shells/dash
parentapp-shells/push: Version bump (diff)
downloadmv-cc532f094f45a677094f9ff6409d3f39068c184d.tar.gz
mv-cc532f094f45a677094f9ff6409d3f39068c184d.tar.bz2
mv-cc532f094f45a677094f9ff6409d3f39068c184d.zip
app-shells/dash: Version bump
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/Manifest2
-rw-r--r--app-shells/dash/dash-0.5.9.1.ebuild (renamed from app-shells/dash/dash-0.5.9-r1.ebuild)12
-rw-r--r--app-shells/dash/dash-99999999.ebuild14
-rw-r--r--app-shells/dash/files/dumb-echo.patch43
4 files changed, 30 insertions, 41 deletions
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index af942a5a..cbc939b2 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -1 +1 @@
-DIST dash-0.5.9.tar.gz 224831 SHA256 92793b14c017d79297001556389442aeb9e3c1cc559fd178c979169b1a47629c
+DIST dash-0.5.9.1.tar.gz 225217 SHA256 5ecd5bea72a93ed10eb15a1be9951dd51b52e5da1d4a7ae020efd9826b49e659
diff --git a/app-shells/dash/dash-0.5.9-r1.ebuild b/app-shells/dash/dash-0.5.9.1.ebuild
index 2ae757ec..b1940ec7 100644
--- a/app-shells/dash/dash-0.5.9-r1.ebuild
+++ b/app-shells/dash/dash-0.5.9.1.ebuild
@@ -16,17 +16,17 @@ then EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dash/dash.git"
PROPERTIES="live"
KEYWORDS=""
SRC_URI=""
-else inherit versionator
- MY_PV="$(get_version_component_range 1-3)"
- DEB_PATCH="$(get_version_component_range 4)"
- MY_P="${PN}-${MY_PV}"
+else # inherit versionator
+ #MY_PV="$(get_version_component_range 1-3)"
+ DEB_PATCH="" #"$(get_version_component_range 4)"
+ #MY_P="${PN}-${MY_PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
- SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${MY_P}.tar.gz"
+ SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
if [ -n "${DEB_PATCH}" ]
then DEB_PF="${PN}_${MY_PV}-${DEB_PATCH}"
SRC_URI=${SRC_URI}" mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
fi
- S=${WORKDIR}/${MY_P}
+ #S=${WORKDIR}/${MY_P}
fi
inherit eutils flag-o-matic toolchain-funcs
diff --git a/app-shells/dash/dash-99999999.ebuild b/app-shells/dash/dash-99999999.ebuild
index 5327b792..b1940ec7 100644
--- a/app-shells/dash/dash-99999999.ebuild
+++ b/app-shells/dash/dash-99999999.ebuild
@@ -16,17 +16,17 @@ then EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dash/dash.git"
PROPERTIES="live"
KEYWORDS=""
SRC_URI=""
-else inherit versionator
- MY_PV="$(get_version_component_range 1-3)"
- DEB_PATCH="$(get_version_component_range 4)"
- MY_P="${PN}-${MY_PV}"
+else # inherit versionator
+ #MY_PV="$(get_version_component_range 1-3)"
+ DEB_PATCH="" #"$(get_version_component_range 4)"
+ #MY_P="${PN}-${MY_PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
- SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${MY_P}.tar.gz"
+ SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
if [ -n "${DEB_PATCH}" ]
then DEB_PF="${PN}_${MY_PV}-${DEB_PATCH}"
SRC_URI=${SRC_URI}" mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
fi
- S=${WORKDIR}/${MY_P}
+ #S=${WORKDIR}/${MY_P}
fi
inherit eutils flag-o-matic toolchain-funcs
@@ -46,7 +46,7 @@ DEPEND="${RDEPEND}
src_prepare() {
local c
default
- ! use cripple || eapply "${FILESDIR}"/dumb-echo
+ ! use cripple || eapply "${FILESDIR}"/dumb-echo.patch
if [ -n "${DEB_PATCH}" ]
then eapply "${WORKDIR}"/${DEB_PF}.diff
eapply */debian/diff/*
diff --git a/app-shells/dash/files/dumb-echo.patch b/app-shells/dash/files/dumb-echo.patch
index 89d51096..cbf5feba 100644
--- a/app-shells/dash/files/dumb-echo.patch
+++ b/app-shells/dash/files/dumb-echo.patch
@@ -1,24 +1,17 @@
http://bugs.gentoo.org/337329
http://bugs.gentoo.org/527848
-http://bugs.gentoo.org/590696
-There's no requirement for `echo` to support escape sequences on systems
-which are not XSI compliant (like embedded systems) according to POSIX:
+there's no requirement for `echo` to support escape sequences. bash, by default,
+does not, while dash always does. POSIX permits either behavior:
http://pubs.opengroup.org/onlinepubs/9699919799/utilities/echo.html
-This behavior breaks historical scripts, espcially if also the (not required
-by POSIX) `echo -n` and `echo -e` are unsupported, in particular all scripts
-generated by autoconf-2.13 will break.
+however, since the behavior is not portable, no one should be relying on echo
+having any specific behavior. they should use `printf` when they want an escape
+sequence. it also makes dash smaller & faster to disable this logic entirely.
-Modern scripts better should avoid all these pitfalls and should always prefer
-`printf` when they want anything like `echo -n` or interpretation of escape
-sequences. So it might be useful to intentionally break scripts which rely on
-these features. Note that this patch makes `echo` in dash behave differently
-from any other existing shell.
-
---- a/src/bltin/printf.c
-+++ b/src/bltin/printf.c
-@@ -442,21 +442,12 @@
+--- dash-0.5.9.1/src/bltin/printf.c
++++ dash-0.5.9.1/src/bltin/printf.c
+@@ -449,21 +449,12 @@
int
echocmd(int argc, char **argv)
{
@@ -32,7 +25,7 @@ from any other existing shell.
-
- if (likely(*argv))
- nonl += print_escape_str("%s", NULL, NULL, *argv++);
-- if (nonl > 0)
+- if (likely((nonl + !*argv) > 1))
- break;
-
- c = *argv ? ' ' : '\n';
@@ -47,9 +40,9 @@ from any other existing shell.
+ outc('\n', out1);
return 0;
}
---- a/src/dash.1
-+++ b/src/dash.1
-@@ -1182,43 +1182,18 @@
+--- dash-0.5.9.1/src/dash.1
++++ dash-0.5.9.1/src/dash.1
+@@ -1182,43 +1182,15 @@
option turns off the effect of any preceding
.Fl P
options.
@@ -61,7 +54,7 @@ from any other existing shell.
-Unless the
-.Fl n
-option is present, a newline is output following the arguments.
--.Pp
+ .Pp
-If any of the following sequences of characters is encountered during
-output, the sequence is not output. Instead, the specified action is
-performed:
@@ -89,15 +82,11 @@ from any other existing shell.
-.It Li \e\e
-Output a backslash.
-.El
++No arguments or backslash sequences are supported as they are not portable.
++They will be printed out exactly as passed in.
.Pp
-All other backslash sequences elicit undefined behaviour.
-+In this crippled version of dash no backslash sequences are supported.
-+They will be printed out exactly as passed in.
-+Also the option -n is not supported in this crippled version of dash.
-+.Pp
-+Moderns scripts might want to replace `echo -n ...` with the `printf %s ...`
-+construct, and similarly use `printf` to for escape sequences. This is POSIX
-+compliant though not compatible since some historical systems lack `printf`.
++You can replace `echo -n ...` with the portable `printf %s ...` construct.
.It eval Ar string ...
Concatenate all the arguments with spaces.
Then re-parse and execute the command.