summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2020-07-26 13:52:41 +0200
committerMartin Väth <martin@mvath.de>2020-07-26 13:52:41 +0200
commitda692069ad515db87c2d977adcbaeb2d9d1c6daa (patch)
tree61dbae9d61de2353388454ee7d514d81be3a5180 /app-shells/quoter/quoter-4.2.ebuild
parentapp-shells/push: Version bump (diff)
downloadmv-da692069ad515db87c2d977adcbaeb2d9d1c6daa.tar.gz
mv-da692069ad515db87c2d977adcbaeb2d9d1c6daa.tar.bz2
mv-da692069ad515db87c2d977adcbaeb2d9d1c6daa.zip
Bumps to add SPDX-License-Identifier
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'app-shells/quoter/quoter-4.2.ebuild')
-rw-r--r--app-shells/quoter/quoter-4.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-shells/quoter/quoter-4.2.ebuild b/app-shells/quoter/quoter-4.2.ebuild
new file mode 100644
index 00000000..63c07f73
--- /dev/null
+++ b/app-shells/quoter/quoter-4.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2016-2020 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" EPREFIX="${EPREFIX}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" EPREFIX="${EPREFIX}" install
+ dodoc README.md
+}