summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /app-shells/set_prompt
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'app-shells/set_prompt')
-rw-r--r--app-shells/set_prompt/Manifest1
-rw-r--r--app-shells/set_prompt/metadata.xml16
-rw-r--r--app-shells/set_prompt/set_prompt-1.22.ebuild33
3 files changed, 50 insertions, 0 deletions
diff --git a/app-shells/set_prompt/Manifest b/app-shells/set_prompt/Manifest
new file mode 100644
index 00000000..12db831c
--- /dev/null
+++ b/app-shells/set_prompt/Manifest
@@ -0,0 +1 @@
+DIST set_prompt-1.22.tar.gz 7981 SHA256 7dd9023da52099d60da7c4e0faca99aa421355c605c713371f2de9fad1d54596 SHA512 48b99c3e611297127059effdc1dadd9b1c50f8d7047922a75368780ea632c4e884cf537c5fa97f668cb7151764b9d42365bbf16c5c87ce612ebcc3881d7ccbb7 WHIRLPOOL 3cbe1b2f9dd0c277c0351165aa1a2d464337f31483dbd0d0629af4fc25490389bb7b1da111779d3bd35ae9de408ab5168a33e345c2e42bec4a8326253c2cb17f
diff --git a/app-shells/set_prompt/metadata.xml b/app-shells/set_prompt/metadata.xml
new file mode 100644
index 00000000..a7fc3713
--- /dev/null
+++ b/app-shells/set_prompt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/set_prompt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/set_prompt/set_prompt-1.22.ebuild b/app-shells/set_prompt/set_prompt-1.22.ebuild
new file mode 100644
index 00000000..94a9288d
--- /dev/null
+++ b/app-shells/set_prompt/set_prompt-1.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="An intelligent prompt for zsh or bash with status line (window title) support"
+HOMEPAGE="https://github.com/vaeth/set_prompt/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}"'/bin/sh"' \
+ -e '1s"^#!/usr/bin/env zsh$"#!'"${EPREFIX}"'/bin/zsh"' \
+ -- * || die
+ epatch_user
+}
+
+src_install() {
+ insinto /etc
+ doins set_prompt.config
+ insinto /usr/bin
+ doins set_prompt.sh git_prompt.zsh
+ dobin set_prompt git_update
+ dodoc README
+}