summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-01-06 21:29:53 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:34 +0200
commit25f0dfbf9319f15b269bf025c7f56edf3f058771 (patch)
tree2dc7b3cb2ece36405e70eb8f9d2ccddde64fd94e /app-shells/termcolors-mv
parentBump zram-init (diff)
downloadmv-25f0dfbf9319f15b269bf025c7f56edf3f058771.tar.gz
mv-25f0dfbf9319f15b269bf025c7f56edf3f058771.tar.bz2
mv-25f0dfbf9319f15b269bf025c7f56edf3f058771.zip
Add termcolors-mv, zshrc-mv
Diffstat (limited to 'app-shells/termcolors-mv')
-rw-r--r--app-shells/termcolors-mv/ChangeLog8
-rw-r--r--app-shells/termcolors-mv/Manifest1
-rw-r--r--app-shells/termcolors-mv/metadata.xml16
-rw-r--r--app-shells/termcolors-mv/termcolors-mv-1.1.ebuild35
4 files changed, 60 insertions, 0 deletions
diff --git a/app-shells/termcolors-mv/ChangeLog b/app-shells/termcolors-mv/ChangeLog
new file mode 100644
index 00000000..cbe20bce
--- /dev/null
+++ b/app-shells/termcolors-mv/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-shells/termcolors-mv
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*termcolors-1.1 (06 Jan 2013)
+
+ 06 Jan 2013; Martin Väth <martin@mvath.de>
+ New ebuild from scratch.
diff --git a/app-shells/termcolors-mv/Manifest b/app-shells/termcolors-mv/Manifest
new file mode 100644
index 00000000..ce0fcbe8
--- /dev/null
+++ b/app-shells/termcolors-mv/Manifest
@@ -0,0 +1 @@
+DIST termcolors-mv-1.1.tar.gz 7823 SHA256 800a9a88f8752d11ae9f38a6b83558868719157855773d43378b05b9718ccc25 SHA512 7688ef3c2b496c0ff37b44525f456004e6d2afa55ea0ce8f215673e1d77aec8058dbcdf37649208b2bd5acdc5d0404978fd40391056df2dbe3a75af2eaeb00c2 WHIRLPOOL 7fa592e10bb80c9ac950f7fa47ea7d4e1bee78cb87b542e80b671a64dd90aa96107b784281960ef2ec07f2186d50d86bd7fcadb26d689f130be612e5218c181e
diff --git a/app-shells/termcolors-mv/metadata.xml b/app-shells/termcolors-mv/metadata.xml
new file mode 100644
index 00000000..e8c87211
--- /dev/null
+++ b/app-shells/termcolors-mv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/termcolors-mv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/termcolors-mv/termcolors-mv-1.1.ebuild b/app-shells/termcolors-mv/termcolors-mv-1.1.ebuild
new file mode 100644
index 00000000..ef43b3dd
--- /dev/null
+++ b/app-shells/termcolors-mv/termcolors-mv-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="256colors sample script and dircolors configuration for standard or 256 colors"
+HOMEPAGE="https://github.com/vaeth/termcolors-mv/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ insinto /etc
+ doins etc/*
+}
+
+pkg_postinst() {
+ elog "To use ${PN} with 256 colors, you have to call"
+ elog " eval \"\`dircolors /etc/DIR_COLORS-256\`\""
+ elog "e.g. in your bashrc."
+ if ! has_version app-shells/zshrc-mv
+ then elog "For zsh, this happens if you use zshrc-mv"
+ fi
+}