summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-07-09 08:15:01 +0200
committerMartin Väth <martin@mvath.de>2016-07-09 08:15:01 +0200
commit4e5e07da99dd4c3e20168057126e3694314a670c (patch)
treeb9643143e9a30baffb66b2d0978ed7fe17fd34dc /app-shells/zsh-completions
parentapp-cdr/xcdroast: Bump changes from main gentoo repository (diff)
downloadmv-4e5e07da99dd4c3e20168057126e3694314a670c.tar.gz
mv-4e5e07da99dd4c3e20168057126e3694314a670c.tar.bz2
mv-4e5e07da99dd4c3e20168057126e3694314a670c.zip
Bourne-compliant parameter substitution
Diffstat (limited to 'app-shells/zsh-completions')
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.18.0.ebuild13
-rw-r--r--app-shells/zsh-completions/zsh-completions-99999999.ebuild4
2 files changed, 7 insertions, 10 deletions
diff --git a/app-shells/zsh-completions/zsh-completions-0.18.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.18.0.ebuild
index d56ebf5e..00da49ba 100644
--- a/app-shells/zsh-completions/zsh-completions-0.18.0.ebuild
+++ b/app-shells/zsh-completions/zsh-completions-0.18.0.ebuild
@@ -10,8 +10,8 @@ case ${PV} in
EGIT_REPO_URI="git://github.com/zsh-users/${PN}.git"
inherit git-r3
PROPERTIES="live"
- KEYWORDS=""
- SRC_URI="";;
+ KEYWORDS=
+ SRC_URI=;;
*)
LIVE=false
#RESTRICT="mirror"
@@ -25,10 +25,7 @@ DESCRIPTION="Additional completion definitions for Zsh"
HOMEPAGE="https://gentoo.org/zsh-users/zsh-completions/"
LICENSE="ZSH"
SLOT="0"
-if ${LIVE}
-then DEPEND=""
-else DEPEND=""
-fi
+DEPEND=
IUSE=""
declare -a FILES
@@ -54,10 +51,10 @@ calculate_data() {
case ${curr} in
'+'*)
curr="completion_${curr#?}"
- IUSE="${IUSE}${IUSE:+ }+${curr}";;
+ IUSE=${IUSE}${IUSE:+\ }+${curr};;
*)
curr="completion_${curr}"
- IUSE="${IUSE}${IUSE:+ }${curr}";;
+ IUSE=${IUSE}${IUSE:+\ }${curr};;
esac
for currfile in ${comp#* }
do used_value currfile
diff --git a/app-shells/zsh-completions/zsh-completions-99999999.ebuild b/app-shells/zsh-completions/zsh-completions-99999999.ebuild
index d56ebf5e..429b307d 100644
--- a/app-shells/zsh-completions/zsh-completions-99999999.ebuild
+++ b/app-shells/zsh-completions/zsh-completions-99999999.ebuild
@@ -54,10 +54,10 @@ calculate_data() {
case ${curr} in
'+'*)
curr="completion_${curr#?}"
- IUSE="${IUSE}${IUSE:+ }+${curr}";;
+ IUSE=${IUSE}${IUSE:+\ }'+'${curr};;
*)
curr="completion_${curr}"
- IUSE="${IUSE}${IUSE:+ }${curr}";;
+ IUSE=${IUSE}${IUSE:+\ }${curr};;
esac
for currfile in ${comp#* }
do used_value currfile