summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-10-12 21:12:31 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:59 +0200
commit5d21146b66819048d79903a55a151e52fc64749c (patch)
tree8f7da4a59d3c1d8a91d1f9f194285e38e81fd29d /app-shells/zsh
parentBump firewall-mv (diff)
downloadmv-5d21146b66819048d79903a55a151e52fc64749c.tar.gz
mv-5d21146b66819048d79903a55a151e52fc64749c.tar.bz2
mv-5d21146b66819048d79903a55a151e52fc64749c.zip
Add fvwm-crystal. Use readme.gentoo.eclass
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog3
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild58
2 files changed, 30 insertions, 31 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 0f821aea..cfe4f5fc 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -4,6 +4,9 @@
*zsh-99999999 (29 May 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
14 Sep 2013; Martin Väth <martin@mvath.de>:
Bump to git-r3.eclass
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
index a0b47bca..bb9598c2 100644
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -7,7 +7,7 @@ EAPI=5
# doc package for -dev version exists?
doc_available=true
-inherit eutils flag-o-matic multilib prefix
+inherit eutils flag-o-matic multilib prefix readme.gentoo
MY_PV=${PV/_p/-dev-}
S=${WORKDIR}/${PN}-${MY_PV}
@@ -87,6 +87,31 @@ PDEPEND="
examples? ( app-doc/zsh-lovers )
"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="
+If you want to enable Portage completions and Gentoo prompt,
+emerge app-shells/zsh-completion and add
+ autoload -U compinit promptinit
+ compinit
+ promptinit; prompt gentoo
+to your ~/.zshrc
+
+Also, if you want to enable cache for the completions, add
+ zstyle ':completion::complete:*' use-cache 1
+to your ~/.zshrc
+"
+
+pkg_setup() {
+ if use run-help
+ then DOC_CONTENTS="
+If you want to use run-help add to your ~/.zshrc
+ unalias run-help
+ autoload -Uz run-help
+ HELPDIR=/usr/share/zsh/site-contrib/help
+${DOC_CONTENTS}"
+ fi
+}
+
src_prepare() {
# fix zshall problem with soelim
ln -s Doc man1
@@ -279,6 +304,7 @@ src_install() {
done
dodoc ChangeLog* META-FAQ NEWS README config.modules
+ readme.gentoo_src_install
if use doc ; then
pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
@@ -291,33 +317,3 @@ src_install() {
docinto StartupFiles
dodoc StartupFiles/z*
}
-
-pkg_postinst() {
- if use run-help ; then
- # In order to avoid confusion of the user, we print the following
- # unconditionally even if an older version of zsh was installed:
- # This older version might be without support for USE=run-help -
- # we cannot tell from the version number in ${REPLACING_VERSIONS}
- # alone and has_version does not work here as desired.
- elog
- elog "If you want to use run-help add to your ~/.zshrc"
- elog " unalias run-help"
- elog " autoload -Uz run-help"
- elog " HELPDIR=/usr/share/zsh/site-contrib/help"
- fi
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # should link to http://www.gentoo.org/doc/en/zsh.xml
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- fi
-}