summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2013-01-26 17:59:35 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:35 +0200
commit3e1950ff2f70e6140f52b244516aab0efb03789c (patch)
tree5d723a4ab7fab0506ad43b3d886a01ba6c48448d /app-shells/zshrc-mv/zshrc-mv-1.6.ebuild
parentBump zshrc-mv (diff)
downloadmv-3e1950ff2f70e6140f52b244516aab0efb03789c.tar.gz
mv-3e1950ff2f70e6140f52b244516aab0efb03789c.tar.bz2
mv-3e1950ff2f70e6140f52b244516aab0efb03789c.zip
Bump zshrc-mv and auto-fu-zsh. Shift kill-line to zshrc-mv
Diffstat (limited to 'app-shells/zshrc-mv/zshrc-mv-1.6.ebuild')
-rw-r--r--app-shells/zshrc-mv/zshrc-mv-1.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/zshrc-mv/zshrc-mv-1.6.ebuild b/app-shells/zshrc-mv/zshrc-mv-1.6.ebuild
new file mode 100644
index 00000000..49f92186
--- /dev/null
+++ b/app-shells/zshrc-mv/zshrc-mv-1.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="A zshrc file initializing zsh specific interactive features"
+HOMEPAGE="https://github.com/vaeth/zshrc-mv/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="!app-shells/auto-fu-zsh[kill-line(-)]"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dodoc README
+ insinto /etc/zsh
+ doins zshrc
+}
+
+pkg_postinst() {
+ local i
+ for i in \
+ '>=app-shells/auto-fu-zsh-0.0.1.13' \
+ 'app-shells/zsh-syntax-highlighting' \
+ 'app-shells/set_prompt' \
+ 'app-shells/termcolors-mv'
+ do has_version "${i}" || elog "It is recommended to install ${i}"
+ done
+}