summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /app-shells/zshrc-mv/zshrc-mv-2.22.ebuild
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'app-shells/zshrc-mv/zshrc-mv-2.22.ebuild')
-rw-r--r--app-shells/zshrc-mv/zshrc-mv-2.22.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/zshrc-mv/zshrc-mv-2.22.ebuild b/app-shells/zshrc-mv/zshrc-mv-2.22.ebuild
new file mode 100644
index 00000000..6f08fdd9
--- /dev/null
+++ b/app-shells/zshrc-mv/zshrc-mv-2.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A zshrc file initializing zsh specific interactive features"
+HOMEPAGE="https://github.com/vaeth/zshrc-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="!app-shells/auto-fu-zsh[kill-line(-)]"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dodoc README
+ insinto /etc/zsh
+ doins zshrc
+}
+
+pkg_postinst() {
+ optfeature "automagic completion" '>=app-shells/auto-fu-zsh-0.0.1.13'
+ optfeature "syntax highlighting" 'app-shells/zsh-syntax-highlighting'
+ optfeature "a nice prompt" 'app-shells/set_prompt'
+ optfeature "nice directory colors" 'app-shells/termcolors-mv'
+}