summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-01-02 13:51:26 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:20 +0200
commit67280bd2985a2baf55a0013313bfac761b542720 (patch)
treec6c36393bf4fec34143f23b3909908a564968a2b /app-shells
parentBump m5figur-mv. Update years (diff)
downloadmv-67280bd2985a2baf55a0013313bfac761b542720.tar.gz
mv-67280bd2985a2baf55a0013313bfac761b542720.tar.bz2
mv-67280bd2985a2baf55a0013313bfac761b542720.zip
Bump m5figur-mv, classic-theme-restorer. Update magus, zsh
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/ChangeLog5
-rw-r--r--app-shells/zsh/files/zsh-5.0.7-pid-ns.patch39
-rw-r--r--app-shells/zsh/zsh-5.0.7-r2.ebuild (renamed from app-shells/zsh/zsh-5.0.7-r1.ebuild)8
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild4
4 files changed, 51 insertions, 5 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 81093b2d..53ede34c 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zsh-5.0.7-r2 (02 Jan 2015)
+
+ 02 Jan 2015; Martin Väth <martin@mvath.de>:
+ Add zsh-5.0.7-pid-ns.patch from gentoo main tree
+
*zsh-5.0.7-r1 (09 Oct 2014)
09 Oct 2014; Martin Väth <martin@mvath.de>:
diff --git a/app-shells/zsh/files/zsh-5.0.7-pid-ns.patch b/app-shells/zsh/files/zsh-5.0.7-pid-ns.patch
new file mode 100644
index 00000000..928ce48b
--- /dev/null
+++ b/app-shells/zsh/files/zsh-5.0.7-pid-ns.patch
@@ -0,0 +1,39 @@
+zsh and pid namespaces don't play very well together. Specifically, when zsh is
+launched inside a new pid namespace, it doesn't take ownership of the process
+group, causing things like SIGINT to be sent to the parent process. Upstream
+bug report here: http://www.zsh.org/mla/workers/2014/msg01769.html.
+
+The first chunk of this diff fixes this problem and has already been applied
+upstream:
+http://sourceforge.net/p/zsh/code/ci/0c4cb0cc1b527f4341f1a39a10f4120aa7c7d594/.
+
+The second chunk is a suggested fix for the warning that zsh prints when
+exiting: http://www.zsh.org/mla/workers/2014/msg01779.html.
+
+diff --git a/Src/jobs.c b/Src/jobs.c
+index a668b07..c6e1bce 100644
+--- a/Src/jobs.c
++++ b/Src/jobs.c
+@@ -2734,7 +2734,7 @@ acquire_pgrp(void)
+ long ttpgrp;
+ sigset_t blockset, oldset;
+
+- if ((mypgrp = GETPGRP()) > 0) {
++ if ((mypgrp = GETPGRP()) >= 0) {
+ long lastpgrp = mypgrp;
+ sigemptyset(&blockset);
+ sigaddset(&blockset, SIGTTIN);
+@@ -2779,8 +2779,11 @@ void
+ release_pgrp(void)
+ {
+ if (origpgrp != mypgrp) {
+- attachtty(origpgrp);
+- setpgrp(0, origpgrp);
++ /* in linux pid namespaces, origpgrp may never have been set */
++ if (origpgrp) {
++ attachtty(origpgrp);
++ setpgrp(0, origpgrp);
++ }
+ mypgrp = origpgrp;
+ }
+ }
diff --git a/app-shells/zsh/zsh-5.0.7-r1.ebuild b/app-shells/zsh/zsh-5.0.7-r2.ebuild
index 45524b6a..d1f584e8 100644
--- a/app-shells/zsh/zsh-5.0.7-r1.ebuild
+++ b/app-shells/zsh/zsh-5.0.7-r2.ebuild
@@ -54,8 +54,8 @@ case ${PV} in
*)
SRC_URI="${ZSH_URI}
doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- #KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ #KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
DEPEND=""
LIVE=false;;
esac
@@ -125,6 +125,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
epatch "${FILESDIR}"/${P}-fix-cvs-completion.patch
+ epatch "${FILESDIR}"/${P}-pid-ns.patch
cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
eprefixify "${T}"/zprofile || die
@@ -277,7 +278,8 @@ src_install() {
if use doc ; then
pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
dohtml -r Doc/*
- dodoc Doc/zsh.{dvi,pdf}
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
popd >/dev/null
fi
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
index c91279f7..9753ffb5 100644
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -54,8 +54,8 @@ case ${PV} in
*)
SRC_URI="${ZSH_URI}
doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- #KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ #KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
DEPEND=""
LIVE=false;;
esac