summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-04-12 09:44:52 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:22 +0200
commit7ad78fb7a7a62142c7737154d83e75516e7ee347 (patch)
treef9b4f6f0b1aaa6d1bdd2ac3a94467020c07ffbb7 /app-shells
parentBump squashount (diff)
downloadmv-7ad78fb7a7a62142c7737154d83e75516e7ee347.tar.gz
mv-7ad78fb7a7a62142c7737154d83e75516e7ee347.tar.bz2
mv-7ad78fb7a7a62142c7737154d83e75516e7ee347.zip
Bump zshrc-mv, zsh-completions, sundtek-tv, noscript
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-completions/ChangeLog5
-rw-r--r--app-shells/zsh-completions/zsh-completions-99999999.ebuild71
-rw-r--r--app-shells/zshrc-mv/ChangeLog52
-rw-r--r--app-shells/zshrc-mv/Manifest2
-rw-r--r--app-shells/zshrc-mv/zshrc-mv-2.16.ebuild (renamed from app-shells/zshrc-mv/zshrc-mv-2.15.ebuild)0
5 files changed, 81 insertions, 49 deletions
diff --git a/app-shells/zsh-completions/ChangeLog b/app-shells/zsh-completions/ChangeLog
index f566a359..7d7493f2 100644
--- a/app-shells/zsh-completions/ChangeLog
+++ b/app-shells/zsh-completions/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zsh-completions-99999999 (12 Apr 2015)
+
+ 12 Apr 2015; Martin Väth <martin@mvath.de>:
+ Update to new/removed completion files. Simplify separation of life version
+
*zsh-completions-0.12.0 (26 Sep 2014)
26 Sep 2014; Martin Väth <martin@mvath.de>:
diff --git a/app-shells/zsh-completions/zsh-completions-99999999.ebuild b/app-shells/zsh-completions/zsh-completions-99999999.ebuild
index d1033fae..3c2fad76 100644
--- a/app-shells/zsh-completions/zsh-completions-99999999.ebuild
+++ b/app-shells/zsh-completions/zsh-completions-99999999.ebuild
@@ -26,7 +26,10 @@ DESCRIPTION="Additional completion definitions for Zsh"
HOMEPAGE="https://gentoo.org/zsh-users/zsh-completions/"
LICENSE="ZSH"
SLOT="0"
-DEPEND="completion_pip? ( !dev-python/pip[zsh-completion] )"
+if ${LIVE}
+then DEPEND=""
+else DEPEND="completion_pip? ( !dev-python/pip[zsh-completion] )"
+fi
IUSE=""
declare -a FILES
@@ -34,51 +37,65 @@ FILES=()
declare -A USEFILE FILEINDEX
USEFILE=()
FILEINDEX=()
-for completion in \
+used_value() {
+ case ${!1} in
+ '*'*)
+ eval ${1}=\${${1}#?}
+ ${LIVE};;
+ '/'*)
+ eval ${1}=\${${1}#?}
+ ! ${LIVE};;
+ esac
+}
+calculate_data() {
+ local comp curr currfile used
+ for comp
+ do curr="${comp%% *}"
+ used_value curr || continue
+ case ${curr} in
+ '+'*)
+ curr="completion_${curr#?}"
+ IUSE="${IUSE}${IUSE:+ }+${curr}";;
+ *)
+ curr="completion_${curr}"
+ IUSE="${IUSE}${IUSE:+ }${curr}";;
+ esac
+ for currfile in ${comp#* }
+ do used_value currfile
+ used=${?}
+ USEFILE["${currfile}"]="${curr}"
+ [[ -z ${FILEINDEX["${currfile}"]} ]] || die "${currfile} listed twice"
+ [ ${used} -ne 0 ] && continue
+ FILEINDEX["${currfile}"]="${#FILES[@]}"
+ FILES+=("${currfile}")
+ done
+ done
+}
+calculate_data \
'+Android _adb _android _emulator' \
'+Google _google' \
'+Unix _cmake _dzen2 _logger _nl _ps _shutdown _watch _xinput' \
'+database _redis-cli _pgsql_utils' \
'+dev _artisan _choc _console _gradle _geany _phing _manage.py _mvn _pear _play _symfony _thor _vagrant _veewee' \
'+disk _sdd _smartmontools _srm' \
- '+distribute _celery _envoy _fab _glances _kitchen _knife _mina _mussh' \
+ '+distribute _celery /_envoy _fab _glances _kitchen _knife _mina _mussh' \
'+filesystem _zfs' \
'+git _git-flow _git-pulls' \
'+hardware _optirun _perf _primus' \
'+haskell _cabal _ghc' \
- '+managers _bower _brew _debuild _lein _pactree _pkcon _port _yaourt' \
+ '+managers _bower _brew *_cask _debuild _lein _pactree _pkcon _port _yaourt' \
'+multimedia _id3 _id3v2 _showoff' \
'+net _dget _dhcpcd _httpie _iw _mosh _rfkill _socat _ssh-copy-id _vpnc _vnstat' \
'+nfs _exportfs' \
'+perl _cpanm' \
- '+pip _pip' \
+ '/+pip _pip' \
'+python _bpython _pygmentize _setup.py' \
'+ruby _bundle _cap _ditz _gas _gem _gist _github _git-wtf _jekyll _lunchy _rails _rspec _rubocop _rvm' \
'+search _ack _ag _jq' \
'+session _atach _teamocil _tmuxinator _wemux' \
'+subtitles _language_codes _periscope _subliminal' \
- '+virtualization _boot2docker _docker _virtualbox _virsh' \
- '+web _coffee _composer _docpad _drush _heroku _jonas _jmeter _jmeter-plugins _lunar _middleman _node _nvm _ralio _salt _sbt _scala _svm'
-do curr=${completion%% *}
- case ${curr} in
- '*'*)
- curr=${curr#?}
- ${LIVE} || continue;;
- esac
- case ${curr} in
- '+'*)
- curr="+completion_${curr#?}";;
- *)
- curr="completion_${curr}";;
- esac
- IUSE=${IUSE}${IUSE:+ }${curr}
- for currfile in ${completion#* }
- do USEFILE["${currfile}"]="${curr#'+'}"
- [[ -z ${FILEINDEX["${currfile}"]} ]] || die "${currfile} listed twice"
- FILEINDEX["${currfile}"]="${#FILES[@]}"
- FILES+=("${currfile}")
- done
-done
+ '+virtualization _boot2docker *_docker-machine /_docker _virtualbox _virsh' \
+ '+web _coffee _composer _docpad _drush _heroku *_hledger _jonas _jmeter _jmeter-plugins _lunar _middleman _node _nvm _ralio _salt _sbt _scala _svm'
src_prepare() {
epatch_user
diff --git a/app-shells/zshrc-mv/ChangeLog b/app-shells/zshrc-mv/ChangeLog
index e1836720..a529bc23 100644
--- a/app-shells/zshrc-mv/ChangeLog
+++ b/app-shells/zshrc-mv/ChangeLog
@@ -2,23 +2,33 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zshrc-2.16 (12 Apr 2015)
+
+ 12 Apr 2015; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
+*zshrc-2.15 (10 Oct 2014)
+
+ 10 Oct 2015; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
*zshrc-2.14 (24 May 2014)
06 Jul 2014; Martin Väth <martin@mvath.de>:
New style github tarball
24 May 2014; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.13 (19 May 2014)
19 May 2014; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.12 (25 Apr 2014)
25 Apr 2014; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.11 (15 Mar 2014)
@@ -31,89 +41,89 @@
Use optfeature
18 Dec 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.9 (21 Nov 2013)
21 Nov 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.8 (12 Nov 2013)
12 Nov 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.7 (31 Aug 2013)
31 Aug 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.6 (09 Aug 2013)
09 Aug 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.5 (04 Aug 2013)
04 Aug 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.4 (09 Jun 2013)
09 Jun 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.3 (19 May 2013)
19 May 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.2 (09 Apr 2013)
09 Apr 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.1 (07 Apr 2013)
07 Apr 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-2.0 (23 Mar 2013)
23 Mar 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild. Support solarized if SOLARIZED is set.
+ Version bump, remove old ebuild. Support solarized if SOLARIZED is set
*zshrc-1.7 (21 Feb 2013)
21 Feb 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-1.6 (26 Jan 2013)
26 Jan 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-1.5 (24 Jan 2013)
24 Jan 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-1.4 (19 Jan 2013)
19 Jan 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-1.3 (14 Jan 2013)
14 Jan 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-1.2 (12 Jan 2013)
12 Jan 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*zshrc-1.1 (06 Jan 2013)
06 Jan 2013; Martin Väth <martin@mvath.de>:
- New ebuild from scratch.
+ New ebuild from scratch
diff --git a/app-shells/zshrc-mv/Manifest b/app-shells/zshrc-mv/Manifest
index 03aaa636..3d7dbdcb 100644
--- a/app-shells/zshrc-mv/Manifest
+++ b/app-shells/zshrc-mv/Manifest
@@ -1 +1 @@
-DIST zshrc-mv-v2.15.tar.gz 8992 SHA256 784ebfe073178357ce3b6808bb9a378d1d3189fe9f9aded7615c5475b9f55581 SHA512 a3d60f98a252d5130f2afa38730d537c6d9a7c6c2470c61c5e97d11c35b7a3f65e9ca35ad947087c46313ed47158aff0d03e55027fe70d0f205f005632993028 WHIRLPOOL ccd12ddb28e3ab672bb5078f13caebd8ca001dabce9db7158612d66d649cedfd14ce5e29831967d2ca9c55028303d3a14f7acf824d0eddf9b22eccb3f3750e73
+DIST zshrc-mv-v2.16.tar.gz 9022 SHA256 699e9f81922170144e0d7bef2d22d8b2ddfa34f5e9c37f34af83eb47582b70a7 SHA512 d3a9ebc9cde626ea5450b86aa40770deb36e839f20fde9d7125fc6ce50c21d4d7da5899266d827e05790e00ef8bae7dbf0f7c1d791ebc9abc2ec30160bbf6f88 WHIRLPOOL 41a9a8b610184b7be56c9c18499a1fa5d600a85d85d4222be931883d62d4c48abdab79b8c741c56b94b24054cb3d0d63b285619c86bd0695de76228fcf121c79
diff --git a/app-shells/zshrc-mv/zshrc-mv-2.15.ebuild b/app-shells/zshrc-mv/zshrc-mv-2.16.ebuild
index d0cafb7c..d0cafb7c 100644
--- a/app-shells/zshrc-mv/zshrc-mv-2.15.ebuild
+++ b/app-shells/zshrc-mv/zshrc-mv-2.16.ebuild