summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-09-08 20:11:14 +0200
committerMartin Väth <martin@mvath.de>2017-09-08 20:45:02 +0200
commit39d6ecc7f0882f3c9fe825453bda88d91986710e (patch)
tree429d7c157387887a7c7e69d237c08d7db089cf4c /app-text/lesspipe/lesspipe-99999999.ebuild
parentapp-portage/logclean: Version bump. Support lz4 (diff)
downloadmv-39d6ecc7f0882f3c9fe825453bda88d91986710e.tar.gz
mv-39d6ecc7f0882f3c9fe825453bda88d91986710e.tar.bz2
mv-39d6ecc7f0882f3c9fe825453bda88d91986710e.zip
app-text/lesspipe: Add alpha, change live. Support brotli, lz4, zstd
Diffstat (limited to 'app-text/lesspipe/lesspipe-99999999.ebuild')
-rw-r--r--app-text/lesspipe/lesspipe-99999999.ebuild44
1 files changed, 29 insertions, 15 deletions
diff --git a/app-text/lesspipe/lesspipe-99999999.ebuild b/app-text/lesspipe/lesspipe-99999999.ebuild
index ef19adbb..3c0cb8b1 100644
--- a/app-text/lesspipe/lesspipe-99999999.ebuild
+++ b/app-text/lesspipe/lesspipe-99999999.ebuild
@@ -13,15 +13,21 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
case ${PV} in
9999*)
- EGIT_REPO_URI="https://github.com/wofr06/${PN}.git"
- EGIT_BRANCH="master"
+ #EGIT_REPO_URI="https://github.com/wofr06/${PN}.git"
+ #EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
+ EGIT_BRANCH="lesspipe"
inherit git-r3
SRC_URI=""
- KEYWORDS=""
-;;
+ KEYWORDS="";;
+*alpha*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="69383636d5e9aa63983d942887d04d6448cfeea9"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
-IUSE="antiword cabextract catdoc +cpio +djvu dpkg +dvi2tty +elinks fastjar +ghostscript gpg +groff hdf5 +html2text id3v2 image isoinfo libplist +links +lynx lzip mp3info mp3info2 netcdf ooffice p7zip pdf pstotext rar rpm +rpm2targz unrar unrtf +unzip +w3m xlhtml"
+IUSE="antiword brotli cabextract catdoc +cpio +djvu dpkg +dvi2tty +elinks fastjar +ghostscript gpg +groff hdf5 +html2text id3v2 image isoinfo libplist +links +lynx lz4 lzip mp3info mp3info2 netcdf ooffice p7zip pdf pstotext rar rpm +rpm2targz unrar unrtf +unzip +w3m xlhtml zstd"
htmlmode="( || ( html2text links lynx elinks w3m ) )"
REQUIRED_USE="!rpm2targz? ( rpm? ( cpio ) )
@@ -30,22 +36,27 @@ REQUIRED_USE="!rpm2targz? ( rpm? ( cpio ) )
amd64-fbsd? ( !antiword !catdoc !dpkg !elinks !fastjar !html2text
!id3v2 !lzip !mp3info !mp3info2 !ooffice !p7zip !pstotext
!rar !rpm !unrtf !w3m !xlhtml )
- alpha? ( !catdoc !fastjar !id3v2 !libplist !mp3info !mp3info2 !netcdf
- !ooffice !pstotext !rar )
- arm? ( !antiword !catdoc !fastjar !html2text !id3v2 !mp3info
+ alpha? ( !brotli !catdoc !fastjar !id3v2 !libplist !mp3info !mp3info2
+ !netcdf !ooffice !pstotext !rar !zstd )
+ arm? ( !antiword !brotli !catdoc !fastjar !html2text !id3v2 !mp3info
!ooffice !pstotext !rar !xlhtml )
- hppa? ( !catdoc !fastjar !hdf5 !libplist !mp3info2 !netcdf
- !ooffice !rar !w3m !xlhtml )
- ia64? ( !antiword !catdoc !fastjar !id3v2 !libplist !mp3info !mp3info2
- !netcdf !ooffice !pstotext !rar !xlhtml )
- ppc64? ( !catdoc !fastjar !ooffice !xlhtml )
- sparc? ( !catdoc !fastjar !id3v2 !libplist !mp3info2 !netcdf
- !ooffice !pstotext )"
+ hppa? ( !catdoc !brotli !fastjar !hdf5 !libplist !mp3info2 !netcdf
+ !ooffice !rar !w3m !xlhtml !zstd )
+ ia64? ( !antiword !brotli !catdoc !fastjar !id3v2 !libplist !mp3info
+ !mp3info2 !netcdf !ooffice !pstotext !rar !xlhtml !zstd )
+ ppc? ( !brotli )
+ ppc64? ( !brotli !catdoc !fastjar !ooffice !xlhtml )
+ sparc? ( !brotli !catdoc !fastjar !id3v2 !libplist !mp3info2 !netcdf
+ !ooffice !pstotext !zstd )"
BOTH_DEPEND="sys-apps/file
app-arch/xz-utils
app-arch/bzip2
dev-lang/perl
+ brotli? ( !alpha? ( !arm? ( !hppa? ( !ia64? ( !ppc? ( !ppc64?
+ ( !sparc? ( app-arch/brotli ) ) ) ) ) ) ) )
+ lz4? ( app-arch/lz4 )
+ zstd? ( !alpha? ( !hppa? ( !ia64? ( !sparc? ( app-arch/zstd ) ) ) ) )
unzip? ( app-arch/unzip )
fastjar? ( !amd64-fbsd? ( !alpha? ( !arm? ( !hppa? ( !ia64? ( !ppc64?
( !sparc? ( app-arch/fastjar ) ) ) ) ) ) ) )
@@ -182,7 +193,10 @@ src_prepare() {
ModifyY 'perldoc'
ModifyU 'unzip' 'fastjar'
Modify1 'unrar' 'rar'
+ ModifyU 'brotli'
+ ModifyU 'lz4'
ModifyU 'lzip'
+ ModifyU 'zstd'
use p7zip; ModifyX '7za'
ModifyU 'cpio' 'cabextract' 'groff'
Modify1 'html2text' 'links' 'lynx' 'elinks' 'w3m'