summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-07-31 00:52:00 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:50 +0200
commit963694e16f0c16f11e7693d0f72035db623d5797 (patch)
tree9e46ed2bdef522c5eea688017eb2f9286f000d62 /app-text/psjoin
parentDefine masters = gentoo (diff)
downloadmv-963694e16f0c16f11e7693d0f72035db623d5797.tar.gz
mv-963694e16f0c16f11e7693d0f72035db623d5797.tar.bz2
mv-963694e16f0c16f11e7693d0f72035db623d5797.zip
Add psjoin. Bump cpplint
Diffstat (limited to 'app-text/psjoin')
-rw-r--r--app-text/psjoin/ChangeLog6
-rw-r--r--app-text/psjoin/Manifest1
-rw-r--r--app-text/psjoin/metadata.xml14
-rw-r--r--app-text/psjoin/psjoin-0.3.ebuild34
4 files changed, 55 insertions, 0 deletions
diff --git a/app-text/psjoin/ChangeLog b/app-text/psjoin/ChangeLog
new file mode 100644
index 00000000..9b9cbbd2
--- /dev/null
+++ b/app-text/psjoin/ChangeLog
@@ -0,0 +1,6 @@
+# ChangeLog for app-text/psjoin
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 31 Jul 2013; Martin Väth <martin@mvath.de>
+ New ebuild from scratch
diff --git a/app-text/psjoin/Manifest b/app-text/psjoin/Manifest
new file mode 100644
index 00000000..03dd9e4a
--- /dev/null
+++ b/app-text/psjoin/Manifest
@@ -0,0 +1 @@
+DIST psjoin-0.3 5122 SHA256 ac7a3f9512b1f6b0ea2bab4b6832431977649e88a0e6abd752fc097a8c0cd583 SHA512 5dd86a6c863f28bcf4e560ce0a1967a2d316f97ef702ac47dbe0db148c2d4164a973de0a8d0e3aa3ef57a08f92520129cebb99f4bce5a539401f1fc273a8c399 WHIRLPOOL 2c8b4b3309dd5d9ee3955c8d7944e5f911e842710a65c7c250210028f86598695ab0d99076790a630028346ad5898a51afc22786826f039294c81671f4b5285b
diff --git a/app-text/psjoin/metadata.xml b/app-text/psjoin/metadata.xml
new file mode 100644
index 00000000..8730610f
--- /dev/null
+++ b/app-text/psjoin/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>VEF00200@nifty.ne.jp</email>
+ <name>Tom Sato</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/psjoin/psjoin-0.3.ebuild b/app-text/psjoin/psjoin-0.3.ebuild
new file mode 100644
index 00000000..8ed83141
--- /dev/null
+++ b/app-text/psjoin/psjoin-0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+
+inherit eutils
+
+DESCRIPTION="concatenate postscript files. From new PostScript Utilities"
+HOMEPAGE="http://homepage3.nifty.com/tsato/tools/psjoin.html"
+SRC_URI="http://homepage3.nifty.com/tsato/tools/${PN} -> ${P}"
+
+LICENSE="psutils"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_unpack() {
+ mkdir -- "${S}"
+ cp -p -- "${DISTDIR}/${P}" "${S}/${PN}"
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin "${PN}"
+}