summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-05-31 11:07:33 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:44 +0200
commitcedf3168d132acf7f5f8b2ffee80848a42165ff5 (patch)
treeb59491390227c47cc06869bf4a799bdb21f76f1a /app-text/stardict
parentAdd zsh live ebuild (diff)
downloadmv-cedf3168d132acf7f5f8b2ffee80848a42165ff5.tar.gz
mv-cedf3168d132acf7f5f8b2ffee80848a42165ff5.tar.bz2
mv-cedf3168d132acf7f5f8b2ffee80848a42165ff5.zip
Add genius to make gnome-doc-utils optional. Fix stardict linking
Diffstat (limited to 'app-text/stardict')
-rw-r--r--app-text/stardict/ChangeLog5
-rw-r--r--app-text/stardict/stardict-3.0.3-r3.ebuild (renamed from app-text/stardict/stardict-3.0.3-r2.ebuild)15
2 files changed, 13 insertions, 7 deletions
diff --git a/app-text/stardict/ChangeLog b/app-text/stardict/ChangeLog
index eae69bb6..c71baa53 100644
--- a/app-text/stardict/ChangeLog
+++ b/app-text/stardict/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 31 May 2013; Martin Väth <martin@mvath.de>:
+ Fix linking without gnome-doc-util. Pull stability from main tree.
+
28 Sep 2012; Martin Väth <martin@mvath.de>:
Bump to EAPI=5
@@ -15,4 +18,4 @@
Inherit base. Add zlib compatibility patch from main tree.
24 Jan 2012; Martin Väth <martin@mvath.de>:
- Copy from tree to make dependencies for help optional. Clean old ChangeLog.
+ Copy from tree to make gnome-doc-utils optional. Clean old ChangeLog.
diff --git a/app-text/stardict/stardict-3.0.3-r2.ebuild b/app-text/stardict/stardict-3.0.3-r3.ebuild
index 36037616..746c3a00 100644
--- a/app-text/stardict/stardict-3.0.3-r2.ebuild
+++ b/app-text/stardict/stardict-3.0.3-r3.ebuild
@@ -13,7 +13,7 @@ EAPI=5
GNOME2_LA_PUNT=yes
GCONF_DEBUG=no
-inherit eutils gnome2 autotools
+inherit autotools eutils gnome2
DESCRIPTION="A international dictionary supporting fuzzy and glob style matching"
HOMEPAGE="http://code.google.com/p/stardict-3/"
@@ -23,7 +23,7 @@ SRC_URI="http://${PN}-3.googlecode.com/files/${P}.tar.bz2
LICENSE="CPL-1.0 GPL-3 LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE="espeak gnome gucharmap qqwry pronounce spell tools"
COMMON_DEPEND=">=dev-libs/glib-2.16
@@ -83,13 +83,16 @@ src_prepare() {
epatch_user
if ! use gnome
then sed -i \
- -e "s/GNOME_DOC_INIT/GNOME_DOC_INIT([0.32],[:],[:])/" \
- -e "/AM_GCONF_SOURCE/d" \
- -e "/help\/Makefile/d" \
+ -e 's/GNOME_DOC_INIT/GNOME_DOC_INIT([0.32],[:],[:])/' \
+ -e '/AM_GCONF_SOURCE/d' \
+ -e '/help\/Makefile/d' \
dict/configure.ac
sed -i \
- -e "s/ help / /" \
+ -e 's/ help / /' \
dict/Makefile.am
+ sed -i \
+ -e 's/\(libstardict_la_LIBADD = \)/\1 -lgmodule-2.0 /' \
+ dict/src/lib/Makefile.am
eautoreconf
fi
gnome2_src_prepare