summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-05-07 23:17:25 +0200
committerMartin Väth <martin@mvath.de>2018-05-07 23:17:25 +0200
commit094d1baa446a429adf4d090893acf7f7c7dd1c49 (patch)
treea7e50c7135cecf533bb6895a0a1df8cbfe8d0d09 /dev-cpp
parentx11-libs/gtk+: Version bump. Remove old (diff)
downloadmv-094d1baa446a429adf4d090893acf7f7c7dd1c49.tar.gz
mv-094d1baa446a429adf4d090893acf7f7c7dd1c49.tar.bz2
mv-094d1baa446a429adf4d090893acf7f7c7dd1c49.zip
Minor cleanups/EAPI bumps
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpplint/cpplint-99999999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-cpp/cpplint/cpplint-99999999.ebuild b/dev-cpp/cpplint/cpplint-99999999.ebuild
index e2f4d8d9..d8ba20d7 100644
--- a/dev-cpp/cpplint/cpplint-99999999.ebuild
+++ b/dev-cpp/cpplint/cpplint-99999999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2012-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( pypy python2_7 )
EGIT_REPO_URI="https://github.com/google/styleguide.git"
inherit elisp-common git-r3 python-single-r1
@@ -19,7 +19,7 @@ EMACSNAME="google-c-style"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
COMMON="emacs? ( virtual/emacs )"
-DEPEND="${COMMON}"
+BDEPEND="${COMMON}"
RDEPEND="${PYTHON_DEPS}
${COMMON}"
@@ -42,7 +42,7 @@ EOF
-e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
-- "${S}/${PN}/${PN}.py" || die
python_fix_shebang "${S}"
- eapply_user
+ default
}
src_compile() {