summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2020-04-04 10:31:51 +0200
committerMartin Väth <martin@mvath.de>2020-04-04 10:31:51 +0200
commitfc67d17fd22f17a6e9efd7071d3702b59372e923 (patch)
tree0695ec54d897fdac80501744c24a8a124523f62d /dev-lang
parentapp-portage/logclean: Version bump (diff)
downloadmv-fc67d17fd22f17a6e9efd7071d3702b59372e923.tar.gz
mv-fc67d17fd22f17a6e9efd7071d3702b59372e923.tar.bz2
mv-fc67d17fd22f17a6e9efd7071d3702b59372e923.zip
dev-lang/python, x11-libs/gtk+: Version bumps
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch28
-rw-r--r--dev-lang/python/python-3.6.10-r1.ebuild (renamed from dev-lang/python/python-3.6.10.ebuild)8
-rw-r--r--dev-lang/python/python-3.7.7-r1.ebuild (renamed from dev-lang/python/python-3.7.7.ebuild)8
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch b/dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch
new file mode 100644
index 00000000..6cae17b5
--- /dev/null
+++ b/dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch
@@ -0,0 +1,28 @@
+From 6e6402caa7962a9c9f7c5327f3c802545824f7f9 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Fri, 3 Apr 2020 10:37:56 -0400
+Subject: [PATCH] test.support.unlink: ignore PermissionError
+
+Resolves test errors when running in the Gentoo sandbox environment.
+
+Bug: https://bugs.gentoo.org/679628
+---
+ Lib/test/support/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Lib/test/support/__init__.py b/Lib/test/support/__init__.py
+index 1f792d8514d..a0772480eb4 100644
+--- a/Lib/test/support/__init__.py
++++ b/Lib/test/support/__init__.py
+@@ -488,7 +488,7 @@ else:
+ def unlink(filename):
+ try:
+ _unlink(filename)
+- except (FileNotFoundError, NotADirectoryError):
++ except (FileNotFoundError, NotADirectoryError, PermissionError):
+ pass
+
+ def rmdir(dirname):
+--
+2.26.0
+
diff --git a/dev-lang/python/python-3.6.10.ebuild b/dev-lang/python/python-3.6.10-r1.ebuild
index e354187f..d0e1ccac 100644
--- a/dev-lang/python/python-3.6.10.ebuild
+++ b/dev-lang/python/python-3.6.10-r1.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test +threads tinfo tk wininst +xml"
RESTRICT="!test? ( test )"
@@ -65,6 +65,7 @@ src_prepare() {
local PATCHES=(
"${WORKDIR}/${PATCHSET}"
+ "${FILESDIR}/test.support.unlink-ignore-PermissionError.patch"
)
! use tinfo || PATCHES+=("${FILESDIR}/curses_tinfo.patch")
@@ -135,6 +136,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--with-fpectl
--enable-shared
$(use_enable ipv6)
diff --git a/dev-lang/python/python-3.7.7.ebuild b/dev-lang/python/python-3.7.7-r1.ebuild
index 3bfc9622..916fe921 100644
--- a/dev-lang/python/python-3.7.7.ebuild
+++ b/dev-lang/python/python-3.7.7-r1.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc ~x86"
IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tinfo tk wininst +xml"
RESTRICT="!test? ( test )"
@@ -66,6 +66,7 @@ src_prepare() {
local PATCHES=(
"${WORKDIR}/${PATCHSET}"
+ "${FILESDIR}/test.support.unlink-ignore-PermissionError.patch"
)
! use tinfo || PATCHES+=("${FILESDIR}/curses_tinfo.patch")
@@ -130,6 +131,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--enable-shared
$(use_enable ipv6)
--infodir='${prefix}/share/info'