summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-04-03 13:15:10 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:45:19 +0200
commit89525b2440ac20ed3a7986aa5fd11970b7907ecb (patch)
treece56af9a4d877fc490dbc832d8f01b2bb9e5a81f /dev-util/ccache
parentBump firefox-plugins. Add noscript (diff)
downloadmv-89525b2440ac20ed3a7986aa5fd11970b7907ecb.tar.gz
mv-89525b2440ac20ed3a7986aa5fd11970b7907ecb.tar.bz2
mv-89525b2440ac20ed3a7986aa5fd11970b7907ecb.zip
Add ccache-3.0_pre0. Reformat metadata.xml
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog8
-rw-r--r--dev-util/ccache/Manifest5
-rw-r--r--dev-util/ccache/ccache-3.0_pre0.ebuild83
-rwxr-xr-xdev-util/ccache/files/ccache-config69
-rw-r--r--dev-util/ccache/metadata.xml13
5 files changed, 178 insertions, 0 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
new file mode 100644
index 00000000..06a7c0a5
--- /dev/null
+++ b/dev-util/ccache/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-util/ccache
+# Copyright 2002-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header $
+
+*ccache-3.0-pre0 (03 Apr 2010)
+
+ 03 Apr 2010; Martin Väth <martin@mvath.de>
+ Version bump from the portage tree; clearing previous ChangeLog.
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
new file mode 100644
index 00000000..60c18fa7
--- /dev/null
+++ b/dev-util/ccache/Manifest
@@ -0,0 +1,5 @@
+AUX ccache-config 1627 RMD160 b5e6a9f509130abd657fd6ec297d7fcbdb094f9d SHA1 698c3235f0685e03f346e4b155897862560974ee SHA256 d438b7d266e17bf95d6c45e619ea8d9040217e70f34eac5cf6fae010f25bb72f
+DIST ccache-3.0pre0.tar.bz2 179291 RMD160 f3001bdb9a29aae874772a80cea2455c4fd5a275 SHA1 26bc8c67f0d7177cf6171cd3fdcd137dc8a67337 SHA256 dbdcbc9f10be423667f030a3a2bbd26b70ebb4821fcbd6547f6c9f9bb06d2b8f
+EBUILD ccache-3.0_pre0.ebuild 2484 RMD160 7af76f32acaa271fd3c63a91b01ff5dd7d68e9e7 SHA1 b7f1eef75577f437c0cd2e808da0c23d6d665255 SHA256 b5548d1476d20efc1eb572a8ffc2951b42c599f5fd7d789627bc704fb4090d85
+MISC ChangeLog 278 RMD160 48184af7b987bd97fab4c08fd56f063fa2d815b5 SHA1 b71d3fb03aed9b7510b7dbcd919cd94f1a321cfd SHA256 717663170f54c08ebb041b41ea95377c52dd4f23b4b45ac9fd7cb8594eb6ae51
+MISC metadata.xml 444 RMD160 99f5113ff8f7ebb2f7ce3e33f855bc6846b8664e SHA1 fde0b5c2db7a88911d98a24052f39c1c525b872f SHA256 4ced2aa742fbd03c11aef10aecd4c62d93fd7f2036a69626d14eb762ae2c131d
diff --git a/dev-util/ccache/ccache-3.0_pre0.ebuild b/dev-util/ccache/ccache-3.0_pre0.ebuild
new file mode 100644
index 00000000..488dd2bf
--- /dev/null
+++ b/dev-util/ccache/ccache-3.0_pre0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+inherit multilib
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+MY_P="${P/_/}"
+SRC_URI="http://samba.org/ftp/ccache/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.X+ installed.
+
+do_links() {
+ insinto /usr/$(get_libdir)/ccache/bin
+ for a in ${CHOST}-{gcc,g++,c++} gcc c++ g++; do
+ dosym /usr/bin/ccache /usr/$(get_libdir)/ccache/bin/${a}
+ done
+}
+
+src_install() {
+ dobin ccache || die
+ doman ccache.1
+ dodoc README
+
+ diropts -m0755
+ dodir /usr/$(get_libdir)/ccache/bin
+ keepdir /usr/$(get_libdir)/ccache/bin
+
+ dobin "${FILESDIR}"/ccache-config || die
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_preinst() {
+ # Do NOT duplicate this in your ebuilds or phear of the wrath!!!
+ if [[ ${ROOT} = "/" ]] ; then
+ einfo "Scanning for compiler front-ends..."
+ do_links
+ else
+ ewarn "Install is incomplete; you must run the following commands:"
+ ewarn " # ccache-config --install-links"
+ ewarn " # ccache-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+}
+
+pkg_postinst() {
+ # nuke broken symlinks from previous versions that shouldn't exist
+ for i in cc ${CHOST}-cc ; do
+ [[ -L "${ROOT}/usr/$(get_libdir)/ccache/bin/${i}" ]] && \
+ rm -rf "${ROOT}/usr/$(get_libdir)/ccache/bin/${i}"
+ done
+ [[ -d "${ROOT}/usr/$(get_libdir)/ccache.backup" ]] && \
+ rm -fr "${ROOT}/usr/$(get_libdir)/ccache.backup"
+
+ elog "To use ccache with **non-Portage** C compiling, add"
+ elog "/usr/$(get_libdir)/ccache/bin to the beginning of your path, before /usr/bin."
+ elog "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ elog "no additional steps. If this is your first install of ccache, type"
+ elog "something like this to set a maximum cache size of 2GB:"
+ elog "# ccache -M 2G"
+ elog
+ elog "If you are upgrading from an older version than 3.x you should run"
+ elog "# CCACHE_DIR=\"${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}\" ccache -C"
+
+ case "${PORTAGE_TMPDIR}/portage/*" in
+ "${CCACHE_BASEDIR:-none}"/*) :;;
+ *)
+ ewarn "To make optimal use of the new direct mode, please set"
+ ewarn " CCACHE_BASEDIR=\"\${PORTAGE_TMPDIR}/portage\""
+ ewarn "in your /etc/make.conf";;
+ esac
+}
diff --git a/dev-util/ccache/files/ccache-config b/dev-util/ccache/files/ccache-config
new file mode 100755
index 00000000..0ca7375d
--- /dev/null
+++ b/dev-util/ccache/files/ccache-config
@@ -0,0 +1,69 @@
+#! /bin/sh
+#
+# ccache-config - helper script for ccache and its ebuild
+#
+# Copyright 2003 Superlucidity Services, LLC
+# This program licensed under the GNU GPL version 2.
+#
+# This script developed by Zachary T Welch at Superlucidity Services, LLC
+# it was cloned from the distcc-config script
+#
+# Ported to POSIX by Martin Väth <martin@mvath.de>
+#
+# Additional features to come; this provides a starting point
+
+# this should be getopt'd someday (override with CC_QUIET=1)
+CC_VERBOSE=1
+
+cc_echo() {
+ [ -z "${CC_QUIET}" ] && [ -n "${CC_VERBOSE}" ] && printf '%s\n' "${*}"
+}
+
+###
+# the following functions manage the ccache symlinks
+# they allow the user or other scripts (namely gcc-config) to
+# automatically update ccache's links when upgrading toolchains
+#
+cc_remove_link() {
+ t="/usr/lib/ccache/bin/${1}"
+ if test -L "${t}"
+ then cc_echo "Removing ${t}..."
+ rm -f -- "${t}"
+ fi
+}
+cc_install_link() {
+ # Search the PATH for the specified compiler
+ # then create shadow link in /usr/lib/ccache/bin to ccache
+
+ if command -v "${1}" >/dev/null 2>&1
+ then # first be sure any old link is removed
+ CC_QUIET=1 cc_remove_link "${1}"
+
+ # then create the new link
+ t="/usr/lib/ccache/bin/${1}"
+ cc_echo "Creating ccache shadow link: ${t}..."
+ ln -s -- /usr/bin/ccache "${t}"
+ fi
+}
+cc_links() {
+ for a in gcc cc c++ g++
+ do [ -n "${2}" ] && a="${2}-${a}"
+ eval "cc_${1}_link" "${a}"
+ done
+}
+
+###
+# main routine
+
+case "${1}" in
+--install-links)
+ cc_links install "${2}"
+ ;;
+--remove-links)
+ cc_links remove "${2}"
+ ;;
+*)
+ printf '%s\n' "Usage: ${0##*/} {--install-links|--remove-links} [ CHOST ]"
+ ;;
+esac
+
diff --git a/dev-util/ccache/metadata.xml b/dev-util/ccache/metadata.xml
new file mode 100644
index 00000000..57e08778
--- /dev/null
+++ b/dev-util/ccache/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+</maintainer>
+<longdescription lang="en">
+ ccache acts as a caching pre-processor to C/C++ compilers, improving
+ compilation time when recompiling previously compiled source.
+</longdescription>
+</pkgmetadata>