summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-03-10 11:49:32 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:47:26 +0200
commit97065335550c7bde6a9cdbfb7ee7152e7198d683 (patch)
treea84c9b681d387e3bcc4b1324bedb3a794cb10cd3 /dev-util/mv_perl/mv_perl-1.4.ebuild
parentBump set_prompt. Security update. See the new README (diff)
downloadmv-97065335550c7bde6a9cdbfb7ee7152e7198d683.tar.gz
mv-97065335550c7bde6a9cdbfb7ee7152e7198d683.tar.bz2
mv-97065335550c7bde6a9cdbfb7ee7152e7198d683.zip
Bump mv_perl, set_prompt
Diffstat (limited to 'dev-util/mv_perl/mv_perl-1.4.ebuild')
-rw-r--r--dev-util/mv_perl/mv_perl-1.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/mv_perl/mv_perl-1.4.ebuild b/dev-util/mv_perl/mv_perl-1.4.ebuild
new file mode 100644
index 00000000..73548b0d
--- /dev/null
+++ b/dev-util/mv_perl/mv_perl-1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+RESTRICT="mirror"
+
+DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
+HOMEPAGE="https://github.com/vaeth/${PN}"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5"
+
+src_unpack() {
+ default
+ cd *"${PN}"-*
+ S="${PWD}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+ fi
+}