summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-09-20 16:58:41 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:18 +0200
commit6e1670643d9e62118f7b166efb643dec962005e9 (patch)
tree7d1e1c732d420e2fd45a48718df3b3c05cb0d1fd /dev-util/mv_perl/mv_perl-2.40.ebuild
parentBump sundtek-tv (diff)
downloadmv-6e1670643d9e62118f7b166efb643dec962005e9.tar.gz
mv-6e1670643d9e62118f7b166efb643dec962005e9.tar.bz2
mv-6e1670643d9e62118f7b166efb643dec962005e9.zip
Bump emount, mv_perl
Diffstat (limited to 'dev-util/mv_perl/mv_perl-2.40.ebuild')
-rw-r--r--dev-util/mv_perl/mv_perl-2.40.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/mv_perl/mv_perl-2.40.ebuild b/dev-util/mv_perl/mv_perl-2.40.ebuild
new file mode 100644
index 00000000..c8f9234e
--- /dev/null
+++ b/dev-util/mv_perl/mv_perl-2.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
+HOMEPAGE="https://github.com/vaeth/mv_perl/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.12"
+# || ( >=dev-lang/perl-5.9.4 >=virtual/perl-File-Spec-3.0 )
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+# || ( >=dev-lang/perl-5.7.3 virtual/perl-Digest-MD5 )
+# || ( >=dev-lang/perl-5.7.3 virtual/perl-Time-HiRes )
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+}