summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-03-27 12:34:56 +0200
committerMartin Väth <martin@mvath.de>2016-03-27 12:34:56 +0200
commit52f8c08a621e2100a74beab4bd48bafa8a038eef (patch)
tree4903995f019e8ba5fc02a2d21294b2d44deb6e9f /dev-util/mv_perl/mv_perl-2.52.ebuild
parentmedia-tv/sundtek-tv: Version bump (diff)
downloadmv-52f8c08a621e2100a74beab4bd48bafa8a038eef.tar.gz
mv-52f8c08a621e2100a74beab4bd48bafa8a038eef.tar.bz2
mv-52f8c08a621e2100a74beab4bd48bafa8a038eef.zip
dev-util/mv_perl: Version bump
Diffstat (limited to 'dev-util/mv_perl/mv_perl-2.52.ebuild')
-rw-r--r--dev-util/mv_perl/mv_perl-2.52.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/mv_perl/mv_perl-2.52.ebuild b/dev-util/mv_perl/mv_perl-2.52.ebuild
new file mode 100644
index 00000000..1716a22d
--- /dev/null
+++ b/dev-util/mv_perl/mv_perl-2.52.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
+HOMEPAGE="https://github.com/vaeth/mv_perl/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.12"
+# || ( >=dev-lang/perl-5.9.4 >=virtual/perl-File-Spec-3.0 )
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+# || ( >=dev-lang/perl-5.7.3 virtual/perl-Digest-MD5 )
+# || ( >=dev-lang/perl-5.7.3 virtual/perl-Time-HiRes )
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+}
+
+pkg_postinst() {
+ optfeature "support to set timestamps of symlinks" 'dev-perl/File-lchown'
+}