summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-10 08:11:05 +0200
committerMartin Väth <martin@mvath.de>2017-07-10 08:11:05 +0200
commit076140811b2689a0e559485b345aa991a8337ad7 (patch)
tree3bf68b863ceb20246266e87aa44e78f6edaf0152 /dev-util
parentwww-plugins/classic-theme-restorer: Version bump (diff)
downloadmv-076140811b2689a0e559485b345aa991a8337ad7.tar.gz
mv-076140811b2689a0e559485b345aa991a8337ad7.tar.bz2
mv-076140811b2689a0e559485b345aa991a8337ad7.zip
Make nonexpensive deps non-optional. Remove corresponding set data
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/comp/comp-4.2.1.ebuild14
-rw-r--r--dev-util/mv_perl/mv_perl-3.10.ebuild16
2 files changed, 15 insertions, 15 deletions
diff --git a/dev-util/comp/comp-4.2.1.ebuild b/dev-util/comp/comp-4.2.1.ebuild
index 5570f170..be7a40ee 100644
--- a/dev-util/comp/comp-4.2.1.ebuild
+++ b/dev-util/comp/comp-4.2.1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
RESTRICT="mirror"
-inherit eutils
DESCRIPTION="compare files or directories, including metadata"
HOMEPAGE="https://github.com/vaeth/comp/"
@@ -14,8 +13,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+# This should really depend on a USE-flag but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND="dev-perl/String-ShellQuote"
+
RDEPEND="!<dev-util/mv_perl-3
->=dev-lang/perl-5.8"
+>=dev-lang/perl-5.8
+${OPTIONAL_RDEPEND}"
# || ( >=dev-lang/perl-5.9.4 >=virtual/perl-File-Spec-3.0 )
# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
@@ -32,7 +36,3 @@ src_install() {
insinto /usr/share/zsh/site-functions
doins zsh/_*
}
-
-pkg_postinst() {
- optfeature "improved output" 'dev-perl/String-ShellQuote'
-}
diff --git a/dev-util/mv_perl/mv_perl-3.10.ebuild b/dev-util/mv_perl/mv_perl-3.10.ebuild
index f5aa3a97..4ce054f8 100644
--- a/dev-util/mv_perl/mv_perl-3.10.ebuild
+++ b/dev-util/mv_perl/mv_perl-3.10.ebuild
@@ -3,7 +3,6 @@
EAPI=6
RESTRICT="mirror"
-inherit eutils
DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
HOMEPAGE="https://github.com/vaeth/mv_perl/"
@@ -14,7 +13,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-lang/perl-5.8"
+# These should really depend on USE-flags but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND="dev-perl/File-lchown
+dev-perl/String-Escape
+dev-perl/String-ShellQuote"
+
+RDEPEND=">=dev-lang/perl-5.8
+ ${OPTIONAL_RDEPEND}"
# || ( >=dev-lang/perl-5.9.4 >=virtual/perl-File-Spec-3.0 )
# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
# || ( >=dev-lang/perl-5.7.3 virtual/perl-Digest-MD5 )
@@ -33,9 +39,3 @@ src_install() {
insinto /usr/share/zsh/site-functions
doins zsh/_*
}
-
-pkg_postinst() {
- optfeature "support to set timestamps of symlinks" 'dev-perl/File-lchown'
- optfeature "improved output" 'dev-perl/String-ShellQuote'
- optfeature "compatible patchdirs output" 'dev-perl/String-Escape'
-}