summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-09-20 21:56:23 +0200
committerMartin Väth <martin@mvath.de>2016-09-20 21:56:23 +0200
commitfdea85085ee5dbf66b9ae48092cda4d1b5c066a2 (patch)
tree620bca054d21d15b8cdb3d52e56035a9e32d530f /dev-vcs/git-wrappers-mv/git-wrappers-mv-1.0.ebuild
parentapp-shells/schily-tools: Version bump (diff)
downloadmv-fdea85085ee5dbf66b9ae48092cda4d1b5c066a2.tar.gz
mv-fdea85085ee5dbf66b9ae48092cda4d1b5c066a2.tar.bz2
mv-fdea85085ee5dbf66b9ae48092cda4d1b5c066a2.zip
dev-vcs/git-wrappers-mv: New ebuild
Diffstat (limited to 'dev-vcs/git-wrappers-mv/git-wrappers-mv-1.0.ebuild')
-rw-r--r--dev-vcs/git-wrappers-mv/git-wrappers-mv-1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-vcs/git-wrappers-mv/git-wrappers-mv-1.0.ebuild b/dev-vcs/git-wrappers-mv/git-wrappers-mv-1.0.ebuild
new file mode 100644
index 00000000..8dcaa92d
--- /dev/null
+++ b/dev-vcs/git-wrappers-mv/git-wrappers-mv-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+
+DESCRIPTION="Some personal wrappers for the most important git commands"
+HOMEPAGE="https://github.com/vaeth/git-wrappers-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}"'/bin/sh"' \
+ -- bin/git-[b-z]* || die
+ eapply_user
+}
+
+src_install() {
+ insinto /usr/bin
+ dobin bin/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc README
+}