summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-02-19 17:30:57 +0100
committerMartin Väth <martin@mvath.de>2017-02-19 17:37:04 +0100
commitae534027c4d06007a2bf89380fd2dfc10161f343 (patch)
treed42b510040f34f536b6bd73e621f57f99ffaa832 /games-board/chessproblem/chessproblem-1.6.ebuild
parentwww-plugins/epubreader: Version bump (diff)
downloadmv-ae534027c4d06007a2bf89380fd2dfc10161f343.tar.gz
mv-ae534027c4d06007a2bf89380fd2dfc10161f343.tar.bz2
mv-ae534027c4d06007a2bf89380fd2dfc10161f343.zip
games-board/chessproblem: Version bumps, slotting
Diffstat (limited to 'games-board/chessproblem/chessproblem-1.6.ebuild')
-rw-r--r--games-board/chessproblem/chessproblem-1.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-board/chessproblem/chessproblem-1.6.ebuild b/games-board/chessproblem/chessproblem-1.6.ebuild
new file mode 100644
index 00000000..11390471
--- /dev/null
+++ b/games-board/chessproblem/chessproblem-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+WANT_LIBTOOL=none
+AT_NOELIBTOOLIZE=yes
+inherit autotools vcs-snapshot
+
+DESCRIPTION="Find solutions of chess problems (mate, selfmate, and helpmate) with cooks"
+HOMEPAGE="https://github.com/vaeth/chessproblem/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="nothreads"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug optimization strong-optimization"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- contrib/test.pl || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable optimization) \
+ $(use_enable strong-optimization)
+}
+
+src_install() {
+ default
+ mv -- "${ED}/usr/bin/chessproblem"{,-nothreads}
+ exeinto "/usr/share/doc/${PF}/"
+ doexe contrib/test.pl
+ docompress -x "/usr/share/doc/${PF}/test.pl"
+}