summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-05-03 14:42:52 +0200
committerMartin Väth <martin@mvath.de>2018-05-03 14:42:52 +0200
commitca568e4625d495310ee54f699610fac4b54c21dd (patch)
treea272783f06f17f76903066e01155a8456a8f7432 /games-rpg/m5figur-mv/m5figur-mv-3.0.ebuild
parentFix mame dirs, sdlmame compilation, python deps (diff)
downloadmv-ca568e4625d495310ee54f699610fac4b54c21dd.tar.gz
mv-ca568e4625d495310ee54f699610fac4b54c21dd.tar.bz2
mv-ca568e4625d495310ee54f699610fac4b54c21dd.zip
games-rpg/m5figur-mv: Version bump
Diffstat (limited to 'games-rpg/m5figur-mv/m5figur-mv-3.0.ebuild')
-rw-r--r--games-rpg/m5figur-mv/m5figur-mv-3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-rpg/m5figur-mv/m5figur-mv-3.0.ebuild b/games-rpg/m5figur-mv/m5figur-mv-3.0.ebuild
new file mode 100644
index 00000000..5339427e
--- /dev/null
+++ b/games-rpg/m5figur-mv/m5figur-mv-3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2014-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+# Do *not* inherit latex-package: It DEPENDS unconditionally on texinfo.
+# Moreover, it would attempt to compile the *.tex example with texinfo to dvi.
+RESTRICT="mirror"
+
+DESCRIPTION="LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)"
+HOMEPAGE="https://github.com/vaeth/m5figur-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+# We need texlive-latexextra for toolbox.sty
+RDEPEND="virtual/latex-base
+ dev-texlive/texlive-latexextra"
+DEPEND="examples? ( ${RDEPEND} )"
+
+src_compile() {
+ if use examples
+ then einfo "Compiling example character sheet as pdf"
+ export VARTEXFONTS="${T}/fonts"
+ pdflatex *.tex && test -s *.pdf || die "could not create example"
+ fi
+}
+
+src_install() {
+ TEXMF="/usr/share/texmf-site"
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.cls
+ insinto "${TEXMF}/doc/latex/${PN}"
+ doins *.tex
+ if use examples
+ then doins *.pdf
+ fi
+ dodoc README.md
+}
+
+pkg_postinst() {
+ texconfig rehash
+}
+
+pkg_postrm() {
+ texconfig rehash
+}