summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-01-24 22:58:16 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:06 +0200
commit46e09afc5b98363762d30e16c0a654aaa0937d40 (patch)
treec5e0159667502734b4bf93a34328276ca0640f04 /games-rpg
parentAvoid duplicate installations (diff)
downloadmv-46e09afc5b98363762d30e16c0a654aaa0937d40.tar.gz
mv-46e09afc5b98363762d30e16c0a654aaa0937d40.tar.bz2
mv-46e09afc5b98363762d30e16c0a654aaa0937d40.zip
Add m5figur-mv
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/m5figur-mv/ChangeLog8
-rw-r--r--games-rpg/m5figur-mv/Manifest1
-rw-r--r--games-rpg/m5figur-mv/m5figur-mv-1.2.ebuild50
-rw-r--r--games-rpg/m5figur-mv/metadata.xml19
4 files changed, 78 insertions, 0 deletions
diff --git a/games-rpg/m5figur-mv/ChangeLog b/games-rpg/m5figur-mv/ChangeLog
new file mode 100644
index 00000000..e7a2bd75
--- /dev/null
+++ b/games-rpg/m5figur-mv/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-rpg/m5figur-mv
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*m5figur-mv-1.1 (24 Jan 2013)
+
+ 24 Jan 2013; Martin Väth <martin@mvath.de>:
+ Initial version from scratch
diff --git a/games-rpg/m5figur-mv/Manifest b/games-rpg/m5figur-mv/Manifest
new file mode 100644
index 00000000..a00db842
--- /dev/null
+++ b/games-rpg/m5figur-mv/Manifest
@@ -0,0 +1 @@
+DIST m5figur-mv-1.2.tar.gz 15549 SHA256 b1bce89dedc8085e95c96b39dff845e55a4890ed740f393ba6dba318a453d21a SHA512 1ab153c5f293da4a22b82dc1e1e08126545a8a81b1c5b5b2540a5662d8299efba556de2f77d0ad1a81351d0049670b31fe4a4f60e8ecdd6702d42d57f3026915 WHIRLPOOL 7f80729b6e229177e4fafde154c97953d275106ecc70f22e9178dcd22791b4d704b708bff415b3b9387f7583744f819733df3e8a65884022eb6ea6238353972a
diff --git a/games-rpg/m5figur-mv/m5figur-mv-1.2.ebuild b/games-rpg/m5figur-mv/m5figur-mv-1.2.ebuild
new file mode 100644
index 00000000..d7985fd3
--- /dev/null
+++ b/games-rpg/m5figur-mv/m5figur-mv-1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+# Do *not* inherit latex-package: It DEPENDS unconditionally on texinfo.
+# Moreover, it would attempt to compile the *.tex example with texinfo to dvi.
+inherit eutils vcs-snapshot
+RESTRICT="mirror"
+
+DESCRIPTION="LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)"
+HOMEPAGE="https://github.com/vaeth/m5figur-mv/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+# We need texlive-latexextra for toolbox.sty
+RDEPEND="virtual/latex-base
+ dev-texlive/texlive-latexextra"
+DEPEND="examples? ( ${RDEPEND} )"
+
+src_compile() {
+ if use examples
+ then einfo "Compiling example character sheet as pdf"
+ export VARTEXFONTS="${T}/fonts"
+ pdflatex *.tex && test -s *.pdf || die "could not create example"
+ fi
+}
+
+src_install() {
+ TEXMF="/usr/share/texmf-site"
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.cls
+ insinto "${TEXMF}/doc/latex/${PN}"
+ doins *.tex
+ if use examples
+ then doins *.pdf
+ fi
+ dodoc README
+}
+
+pkg_postinst() {
+ texconfig rehash
+}
+
+pkg_postrm() {
+ texconfig rehash
+}
diff --git a/games-rpg/m5figur-mv/metadata.xml b/games-rpg/m5figur-mv/metadata.xml
new file mode 100644
index 00000000..f388f698
--- /dev/null
+++ b/games-rpg/m5figur-mv/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/m5figur-mv</remote-id>
+ </upstream>
+ <use>
+ <flag name="examples">Compile example character sheet as PDF</flag>
+ </use>
+</pkgmetadata>