summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-11-28 20:25:29 +0100
committerMartin Väth <martin@mvath.de>2017-11-28 20:25:29 +0100
commit978411f64ffde5cea28442ef039ab77b11105016 (patch)
treedf0d5d991616a89f0af82fa5fcf868e091435220 /mail-client
parentwww-plugins/stylus: Version bump (diff)
downloadmv-978411f64ffde5cea28442ef039ab77b11105016.tar.gz
mv-978411f64ffde5cea28442ef039ab77b11105016.tar.bz2
mv-978411f64ffde5cea28442ef039ab77b11105016.zip
mail-client/alpine: Version bump. Update ebuild from gentoo repository
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alpine/Manifest1
-rw-r--r--mail-client/alpine/alpine-2.21.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index dcf5766f..ee8eb046 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,2 +1,3 @@
DIST alpine-2.00-chappa-115-all.patch.gz 212705 SHA512 5e9fcb6a80dbd18bed26109caa6b7aa5eeb88de420861d9998c32f031e8279d6367c28b6670fb54203d1b14c3dc47cf5ad25b42e4949157de64f3f1fd36d0aa7
DIST alpine-2.00.tar.bz2 5222673 SHA512 17c6e65fbe767d4f9ffb3d3c2bb3deeab9d3620cd046cbb0009290aa484c9254effa992957631f0603bd82b82aeca2923d391aee6d20a7684d5830fbca8ce4d2
+DIST alpine-2.21.tar.xz 4720856 SHA512 a2a36a033c8af79810816a7da7185c269808ba6d84d013691fd8b3764c63f5fb2284e6844ec5a5e99d168514ae636debf59fae962533a2916679e4e9109c6264
diff --git a/mail-client/alpine/alpine-2.21.ebuild b/mail-client/alpine/alpine-2.21.ebuild
new file mode 100644
index 00000000..d73824b0
--- /dev/null
+++ b/mail-client/alpine/alpine-2.21.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="alpine is an easy to use text-based based mail and news client"
+HOMEPAGE="http://www.washington.edu/alpine/ http://alpine.freeiz.com/alpine/ http://repo.or.cz/alpine.git/"
+SRC_URI="http://alpine.freeiz.com/alpine/release/src/${P}.tar.xz https://sources.voidlinux.eu/${P}/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~alpha ~ia64 ~ppc ~sparc"
+IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine pam passfile smime spell ssl threads"
+
+DEPEND="pam? ( virtual/pam )
+ >=sys-libs/ncurses-5.1:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )
+ spell? ( app-text/aspell )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ !onlyalpine? ( !mail-client/pine )
+ !<=net-mail/uw-imap-2004g
+"
+
+src_prepare() {
+ sed -ie 's/AC_CHECK_LIB[^(]*([^,]*pam[^,]*,[^,]*,/AS_IF(['$(
+ usex pam true false)'],/' -- "${S}"/configure.ac
+ default
+ eautoreconf
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ )
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+ econf \
+ $(use_with ldap) \
+ $(use_with ssl) \
+ $(use_with passfile passfile .pinepwd) \
+ $(use_with kerberos krb5) \
+ $(use_with threads pthread) \
+ $(use_with spell interactive-spellcheck /usr/bin/aspell) \
+ $(use_enable nls) \
+ $(use_with ipv6) \
+ $(use_with smime) \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ emake -j1 AR=$(tc-getAR)
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/alpine.1
+ else
+ emake DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+
+ dodoc NOTICE README*
+
+ if use doc ; then
+ dodoc doc/brochure.txt
+
+ docinto html/tech-notes
+ dodoc -r doc/tech-notes/*.html
+ dodoc -r doc/tech-notes/*.txt
+ fi
+}