summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-10-18 22:40:33 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:59 +0200
commit2013b6b4cf1cf0cb907dc902068d5a24d6081f03 (patch)
tree6281f57d48396b27d570a5307c033fd7dd05a1e3 /media-gfx/pqiv/pqiv-2.0.ebuild
parentBump firewall-mv (diff)
downloadmv-2013b6b4cf1cf0cb907dc902068d5a24d6081f03.tar.gz
mv-2013b6b4cf1cf0cb907dc902068d5a24d6081f03.tar.bz2
mv-2013b6b4cf1cf0cb907dc902068d5a24d6081f03.zip
Add pqiv[gtk2]. Bump noscript
Diffstat (limited to 'media-gfx/pqiv/pqiv-2.0.ebuild')
-rw-r--r--media-gfx/pqiv/pqiv-2.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-gfx/pqiv/pqiv-2.0.ebuild b/media-gfx/pqiv/pqiv-2.0.ebuild
new file mode 100644
index 00000000..5f3220bf
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit linux-info toolchain-funcs eutils
+
+DESCRIPTION="Modern rewrite of Quick Image Viewer"
+HOMEPAGE="http://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk2 kernel_linux"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/cairo
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch_user
+}
+
+src_configure() {
+ local gtkver=3
+ ! use gtk2 || gtkver=2
+ ./configure --gtk-version=${gtkver} --prefix=/usr --destdir="${D}" || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dodoc README.markdown
+}