summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-08-27 20:25:09 +0200
committerMartin Väth <martin@mvath.de>2016-08-27 20:25:09 +0200
commit107c23a3f9bd3a721ebf728c1e6f5416c65e40eb (patch)
treeddc05ec812c054fd059b11c0ecc97ccb3d85bb1c /media-libs
parentapp-portage/portage-postsyncd-mv: Version bump (diff)
downloadmv-107c23a3f9bd3a721ebf728c1e6f5416c65e40eb.tar.gz
mv-107c23a3f9bd3a721ebf728c1e6f5416c65e40eb.tar.bz2
mv-107c23a3f9bd3a721ebf728c1e6f5416c65e40eb.zip
Fix live address and python usage
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.12.ebuild7
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild17
2 files changed, 13 insertions, 11 deletions
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.12.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.12.ebuild
index 32c4ed08..0ee0c857 100644
--- a/media-libs/avidemux-core/avidemux-core-2.6.12.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-2.6.12.ebuild
@@ -18,10 +18,11 @@ KEYWORDS="~amd64 ~x86"
MY_PN="${PN/-core/}"
if [[ ${PV} == *9999* ]] ; then
+ MY_P=$P
KEYWORDS=""
- EGIT_REPO_URI="git://gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git https://git.gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git"
-
- inherit git-2
+ PROPERTIES="live"
+ EGIT_REPO_URI="https://github.com/mean00/avidemux2"
+ inherit git-r3
else
MY_P="${MY_PN}_${PV}"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild
index ff7df91b..a1c2e647 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild
@@ -4,9 +4,9 @@
EAPI=6
RESTRICT="fetch"
-#PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils eutils flag-o-matic # python-single-r1
+inherit cmake-utils eutils flag-o-matic python-single-r1
SLOT="2.6"
@@ -20,16 +20,17 @@ KEYWORDS="~amd64 ~x86"
MY_PN="${PN/-plugins/}"
if [[ ${PV} == *9999* ]] ; then
+ MY_P=$P
KEYWORDS=""
- EGIT_REPO_URI="git://gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git https://git.gitorious.org/${MY_PN}2-6/${MY_PN}2-6.git"
-
- inherit git-2
+ PROPERTIES="live"
+ EGIT_REPO_URI="https://github.com/mean00/avidemux2"
+ inherit git-r3
else
MY_P="${MY_PN}_${PV}"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
fi
-DEPEND="
+RDEPEND="
~media-libs/avidemux-core-${PV}:${SLOT}[vdpau?]
~media-video/avidemux-${PV}:${SLOT}[opengl?,qt4?]
>=dev-lang/spidermonkey-1.5-r2:0=
@@ -68,8 +69,8 @@ DEPEND="
vorbis? ( media-libs/libvorbis:0 )
vpx? ( media-libs/libvpx:0 )
"
-# ${PYTHON_DEPS}
-RDEPEND="$DEPEND"
+DEPEND="$RDEPEND
+ ${PYTHON_DEPS}"
S="${WORKDIR}/${MY_P}"