summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-11-17 10:48:10 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:33 +0200
commit38c6c61ee187f3e3f926a11a3f857a3e60fcb43d (patch)
tree0c4770f5c55e9c5c9f64b47b341eac98fda253e0 /media-video/video-mv/video-mv-5.12.ebuild
parentAdd lesspipe (diff)
downloadmv-38c6c61ee187f3e3f926a11a3f857a3e60fcb43d.tar.gz
mv-38c6c61ee187f3e3f926a11a3f857a3e60fcb43d.tar.bz2
mv-38c6c61ee187f3e3f926a11a3f857a3e60fcb43d.zip
Bump runtitle video-mv starter squash_dir kernel noscript auto-fu-zsh
Diffstat (limited to 'media-video/video-mv/video-mv-5.12.ebuild')
-rw-r--r--media-video/video-mv/video-mv-5.12.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/video-mv/video-mv-5.12.ebuild b/media-video/video-mv/video-mv-5.12.ebuild
new file mode 100644
index 00000000..1316b7e1
--- /dev/null
+++ b/media-video/video-mv/video-mv-5.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="A frontend for using mplayer and mencoder as a video recorder"
+HOMEPAGE="https://github.com/vaeth/video-mv/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libav +title zsh-completion"
+RDEPEND="app-shells/push
+ title? ( >=app-shells/runtitle-2.3[zsh-completion?] )
+ !libav? ( media-video/mplayer )
+ libav? ( media-video/libav )"
+DEPEND=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}" || ! test -x "${i}"
+ then doins "${i}"
+ else dobin "${i}"
+ fi
+ done
+ insinto /etc
+ doins etc/*
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ fi
+ dodoc README
+}